Results 1 to 8 of 8

Thread: Problems x2!!!!

  1. #1
    bradsta's Avatar
    Join Date
    Dec 2008
    Location
    Melbourne, Australia
    Posts
    139
    +1
    2

    Problems x2!!!!

    I have a couple of problems with my ski mods! (rxt 215, 2007model)
    1st problem is i got a riva free flow exhaust, took out the resonator what a pain in the #*#, but when i sit it all in there it looks too short and doesn't reach the exit exhaust rubber hose???
    2nd problem is i have a worx intake grate i am putting in, got the old bolts out then SNAP, i broke one that goes into the brass insert, also the grate seems to not sit flat it rocks a bit on the plastic plate that has the inserts in it.
    I am sure someone can help me out


  2. #2

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    You broke the bolts putting them back in or taking them out? I have a grate to install also and its scaring me. Yeah that resonator is a PITA also. I had to cut mine.

  3. #3
    bradsta's Avatar
    Join Date
    Dec 2008
    Location
    Melbourne, Australia
    Posts
    139
    +1
    2
    Broke it taking it out! You can feel tension on the socket driver when undoing them but was not excessive, got them all out and it was the last one!!!!!!

  4. #4

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Did you heat them first? Many told me to heat them.

  5. #5
    bradsta's Avatar
    Join Date
    Dec 2008
    Location
    Melbourne, Australia
    Posts
    139
    +1
    2
    Nup, spoke to the guys at seadoo centre (aus) they said try and do it without heat as being a brass insert in plastic, it is very easy to overheat and melt the plastic. The bolt threads don't look to have loctite on them just a rubbery like substance like silicone in the threads?

  6. #6

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    I found this picture on here somewere while searching intake grate removal. It says a heat gun. So can you still get the bolt out then? I hope the insert doesnt spin on ya. That would really suck.

  7. #7
    bradsta's Avatar
    Join Date
    Dec 2008
    Location
    Melbourne, Australia
    Posts
    139
    +1
    2
    Thanks for that info speed freak, good news i got the bolt out. I drilled pilot holes and used a screw extractor and got it out without damaging the insert!!!!. But my grate doesn't sit flat it rocks on the plastic, not sure if i should remove some of the plastic or the back of the grate? It also sits alot lower than the ride plate level. And any thoughts on the riva exhaust problem??

  8. #8

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    I cant help ya there. I got a riva waterbox coming so I dont have any experience with that setup.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Strange problem with my X2
    By Pendragon in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-26-2011, 10:40 PM
  2. Troubleshooting the Rotax Racing Stage I kit (was problems)
    By Jarrett in forum 4-Tec Performance
    Replies: 104
    Last Post: 10-22-2005, 08:12 PM
  3. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM
  4. Mysterious problem on my RXP
    By Jeff C in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2005, 10:08 AM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •