Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Joe
    Join Date
    Jul 2008
    Posts
    248

    Got some speed issues.....

    '06 RXP - 85 Hours
    Engine / Pump Mods:
    Denso Plugs
    GW SC
    4" Kanaflex - Spectre SS Filter Up front
    Riva Intake Hood w/ 5" Kanaflex feed into hull through Storage Bin
    Solas 14/19R
    2 Degree Riva Wedge
    Oil level is perfect between lines while hot

    Handling Mods:
    R&D Aquavein Intake Grate
    NOPAS
    Riva Sponsons (lowest setting possible)
    Ride Plate holes filled.....

    Ran some speed runs Saturday and having some issues.......

    I weigh 205lbs.
    3/4 tank of fuel
    water temp 75
    Air Temp 70
    WATER GLASS
    Tried with trim up and at one notch above Half
    RPM's 8180 all day long

    BEST SPEED 67.4 MPH Lowrance H2O GPS Velcro'd to Glove Box

    What gives? Any ideas. I am disappointed to say the least....
    Last edited by OneEyedHito; 01-04-2010 at 06:09 PM.


  2. #2
    is thinking. grantuk's Avatar
    Join Date
    Sep 2006
    Location
    Surrey, UK
    Posts
    745
    +1
    19
    you need to add some pitch to that prop, you're on the limiter

  3. #3
    Joe
    Join Date
    Jul 2008
    Posts
    248

    Oh boy....

    thanks for the reply......

    So 8180 is the limiter? I have seen the tach hit 8400 when I have come out of the water, so I thought the limiter was higher than 8180. Makes sense though because the tach pegged at 8180 as soon as the dash speedo hit 69 and stayed there....

  4. #4

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    I would say...
    - Aquavein grate isn't known for top speed. Riva is fast, though.
    - As mentioned, tweak the prop to get it down below 8150.
    - Raise the sponsons. I think low is slow.
    - Run the trim two clicks from the top.
    - Lower the fuel level.

    Your combo should be good for 72-74 mph.

  5. #5

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    Quote Originally Posted by OneEyedHito View Post
    thanks for the reply......

    So 8180 is the limiter? I have seen the tach hit 8400 when I have come out of the water, so I thought the limiter was higher than 8180. ...
    The limiter is progressive. It starts pulling power around 8150.

  6. #6
    Joe
    Join Date
    Jul 2008
    Posts
    248

    good info

    Thanks for the suggs Mike. I was thinking the sponsons being low could be dragging me arse down.....

    I am hesitant on the prop pitching.......can I buy a different pitch prop that would be more suited to this setup?

    I was thinking about a new intake grate also, so i will try to find a Riva......are you suggesting the 'Toploader'?

    Joe

  7. #7

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    Quote Originally Posted by OneEyedHito View Post
    I am hesitant on the prop pitching.......can I buy a different pitch prop that would be more suited to this setup?

    I was thinking about a new intake grate also, so i will try to find a Riva......are you suggesting the 'Toploader'?
    You could try a 15/20, but it may be a little too much.

    I think the "toploader" is the only one they sell for the RXP.

  8. #8
    Joe
    Join Date
    Jul 2008
    Posts
    248

    so I when all you GH'ers get back from MB...

    and have a 15/20R 4 blade and / or a Riva Toploader for sale......Please PM me the $ including PP??????

  9. #9

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3
    you have the right prop, chances are it might need to be repitched. I would swap that grate for a riva though, that could be you issue, and swap up your sponsons..

    or maybe its just the pilot

  10. #10
    Joe
    Join Date
    Jul 2008
    Posts
    248
    Quote Originally Posted by CarFanatic View Post
    you have the right prop, chances are it might need to be repitched. I would swap that grate for a riva though, that could be you issue, and swap up your sponsons..

    or maybe its just the pilot
    Just reread this seeing as I am selling the ski, and realized that you are not Cool!!!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Having some top speed issues with my 2006 GP1300r
    By riick370 in forum Yamaha PWC Performance (2-stroke)
    Replies: 38
    Last Post: 01-11-2017, 12:04 AM
  2. Finally got in some speed runs today
    By Greggpru in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2016, 06:55 PM
  3. I've got a major issue with a repair shop..... need some opinions
    By dr.ipper in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 08-15-2008, 07:59 PM
  4. New to the forum...got some questions
    By BlackHawk in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-20-2006, 05:03 PM
  5. Finally got some GPS numbers on Carey's ski
    By Green Hulk in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-20-2006, 07:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •