Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109

    Genesis I not starting

    Hi guys,

    I just bought a 2001 Genesis I. It does not turn over. I do have power to the solonoid and it is 12v. I just charged the battery as well. The bilge pump works as does the mfd. I have another Genesis that is carbed so I can have test parts available. Any suggestions of what to test for first. When I press the start button , I do not get 12v on the opposite side.

    Thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Does the solenoid click when you press the start button?

    If yes, then the solenoid may have failed. If it has a black plastic body, they are known to fail. The newer version has a light brown body, and is more reliable.

    When you short the two heavy terminals on the solenoid together, does the engine crank? There will be sparking, so use a firm hand to miminize the sparks.

  3. #3

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    I seem to hear a slight click but not the powerful click as if the starter wasn't engaging

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Quote Originally Posted by jukican View Post
    I seem to hear a slight click but not the powerful click as if the starter wasn't engaging
    Test the battery voltage with a multi-meter. Put the meter probes right on the battery posts.

    When you press the start button, does the voltage stay over 10.5 volts?

    If not, the battery is bad.

    If battery is good, then remove and clean both ends of both battery cables - all four ends. Pay special attention to the engine ground connection at the engine block.

  5. #5

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    Voltage remains at 12.4, slight drop when start button depressed, removed terminals and cleaned as well as the block, have not done the starter yet. Can the solonoid be jumped?

  6. #6
    drwebb drwebb69's Avatar
    Join Date
    May 2007
    Location
    okla
    Posts
    170

    starter

    are you sure the motor isnt locked up? if it isnt you might pull the starter and check it. make sure you have good grounds also .

  7. #7
    drwebb drwebb69's Avatar
    Join Date
    May 2007
    Location
    okla
    Posts
    170

    solenoid

    yes you can cross the solenoid but make sure you do it solidly because it will cause a spark.try it and let us know

  8. #8

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    The motor is not locked....when I cross the solonoid your right it sparks but the engine also turns over... I didn't keep it turning over, just to make sure the starter is functioning......Solonoid or starter switch...I have a 99 I can borrow parts from...

  9. #9

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    OK I swapped the solonoid from my 99 Genesis. Now it turns over.....I can hear clicking from the injectors as well, what should I do next to prepare to try and start it.....

  10. #10

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    So, I tried to start it....and it did!!! When I bought the ski, the guy told me it didn't run, the computer was out, but with the ski. He took the ski in payment for another boat. He said he didn't have time to mess with it. I purchased a computer and injectors for it because he thought thats what was wrong with it....Well, when it started, it smoked alot so I shut it down. I don't have any experience with the FFI. Should I put it in the water to see what happens??? When I gave it a small shot of fuel, the rpm's increased and stayed high. I don't want to mess with it until I get it in water. Any suggestions now would be appreciated.\

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Genesis 2001 NOT starting
    By Jim D in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-30-2014, 10:15 AM
  2. 2001 genesis - will not start
    By Cheepjeep80 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-29-2011, 10:22 AM
  3. 1999 carb genesis will not start
    By electrician112159 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-05-2009, 09:46 PM
  4. 2000 Genesis will not "stop" starting
    By backrivertom in forum Polaris Open Discussion
    Replies: 8
    Last Post: 08-07-2008, 04:57 PM
  5. Genesis FFI will not start
    By ab750 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 08-06-2008, 08:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •