Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Join Date
    May 2009
    Location
    SC
    Posts
    81

    new rxp owner and some problems

    I just bought a 07 seadoo rxp 215. It was kind of a last minute decision. I actually saw the ski on ebay and the price was right, so now it's in my driveway lol. Bought it from a dealer as a bank repo. They couldn't tell me much about it. From the research I have done on here, it appears to have the riva stage 1 kit on it. I can spot the pump wedge, riva grate, and riva intake, and also the impeller looks very shiny with a green ring on it ( I was looking up through the grate under the ski) so it might be aftermarket (solas) as well. The ski has 97 hrs on it and it appears the supercharger has been messed with as well because I see sealant around where the case joins. I am hoping the previous owner put in metal washers. Is there any way to tell without pulling the charger? Also I took the ski out on the lake for a test run and it is running like crap. It hesitates and wont reach max rpms. I can best describe it as being very jerky. It will have short bursts of power and pull up to like 7600rpms for a sec then drop down to around 6000 and be very sluggish and slow at only 55mph. I am pretty sure these skis should be around 8K at WOT. I quickly pulled it out of the water to check it, because it didn't feel right. I checked the oil and it was a bit overfilled, so i took some out to get it in between the two notches. Also when checking the spark plugs I found they were only hand tight and looked old, maybe the originals. I have some new ones on order and will pick them up tomorrow. I am thinking the spark plugs may be the root cause of the hesitiation/jerking/low rpms. How do these skis act when the spark plugs go bad on them? I am also putting some fresh 93 in the tank to rule out bad gas. I am praying that it's not the supercharger and something simple like the plugs. I could here the charger spool when riding, so it should be good, right? Like I said, it looks like it was worked on already. Hopefully it will be up and running great tomorrow with the new plugs and I wont have to worry. I am keeping my fingers crossed. Here are some pics:








  2. #2
    Nedo69's Avatar
    Join Date
    Feb 2009
    Location
    Wollongong, Australia
    Posts
    67
    Pull that charger out and check the washers to make sure they are metal!!!!!. Can check the clutch slip while your at it. This process is easy enuf to do. Maybe there was some bad fuel in there as well

  3. #3
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    Looks nice and shiny. Did ya get a good price?

    OBJ

  4. #4

    Join Date
    May 2009
    Location
    SC
    Posts
    81
    Thanks. Yea, the ski still looks like brand new inside and out. I think I got a pretty good deal on it at $6400 with trailer out the door.

  5. #5
    dduck dduck1628's Avatar
    Join Date
    Apr 2007
    Location
    St Augustine FL
    Posts
    623
    I agree with Nedo69. Check that SC for metal washers 1st. Look at the links to the left and clink on supercharger rebuild. I've read great things about him. Also if it is a stage 1. I would expect it to run 70 ant 7700-7800 RPM. You can also get in touch with a dealer and have them run the serial number for warranty repairs.
    Do you have a compression tester? Certainly would hurt to check it to rule out any serious engine problems...

  6. #6

    Join Date
    May 2009
    Location
    SC
    Posts
    81
    Update: I just took it for a test ride today after putting in some new plugs and fresh gas and all I can say is wow. This thing hauls. No more bucking or hesitation here, it just gets up and moves out. Does anyone know if the stock speedo will read past 70mph? It seems to reach it really quick and hold steady. My rpms are at 8100 at WOT. I don't have a gps yet, so I have no clue how fast I am really going. What is the best position on the trim for top speed with the stage 1 pump wedge installed?

  7. #7
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    Sounds like it's running good now. Congrats on the ski. 8100 is perfect for rpm. Best speed will usually be at 1 notch above center on trim although I have no experience with the wedge. You might think about changing the oil since you don't know how many hours are on that oil or what brand it is. Stick some AMSOIL marine synthetic in it. With stage 1, it ought to doo a good 72-73 I think.

  8. #8
    paulthepwner's Avatar
    Join Date
    Mar 2009
    Location
    Middle River, MD
    Posts
    214
    Quote Originally Posted by mustangtw View Post
    Update: I just took it for a test ride today after putting in some new plugs and fresh gas and all I can say is wow. This thing hauls. No more bucking or hesitation here, it just gets up and moves out. Does anyone know if the stock speedo will read past 70mph? It seems to reach it really quick and hold steady. My rpms are at 8100 at WOT. I don't have a gps yet, so I have no clue how fast I am really going. What is the best position on the trim for top speed with the stage 1 pump wedge installed?
    Stock speedo will only go to 70, and you can figure that 70 on the speedo is about 65 GPS

  9. #9

    Join Date
    May 2009
    Location
    SC
    Posts
    81
    Cool, thanks. I'll see if I can find a gps so I can check the speed. I will be changing the oil soon too, even though it does look pretty clean.

  10. #10
    Quote Originally Posted by SeaGoat View Post
    Best speed will usually be at 1 notch above center on trim although I have no experience with the wedge.
    I do 1-2 clicks from the center on the gauge you may want to play with it depending on how much you weigh I weigh 145 lbs. before Beer
    Last edited by Jammer 1; 06-23-2009 at 03:50 AM.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new rxp owner and need some advice
    By Branden in forum 4-Tec Performance
    Replies: 132
    Last Post: 10-05-2014, 06:52 PM
  2. New ski owner and some questions...
    By mdugas in forum Polaris Open Discussion
    Replies: 12
    Last Post: 04-25-2012, 10:23 PM
  3. New RXP wider and taller ?
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 01-11-2008, 06:40 PM
  4. Experince with the New RXP-X and RXT-T
    By mirzar1 in forum 4-Tec Performance
    Replies: 18
    Last Post: 11-11-2007, 08:46 AM
  5. I saw a new rxp owner this weekend.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-08-2005, 06:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •