Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    cfillingi's Avatar
    Join Date
    Jun 2009
    Location
    Molino, Florida
    Posts
    39

    96 Polaris slx 780 starving for fuel???

    I just bought this ski the other day off of craigslist and it had a problem getting fuel. I took some gas line and bypassed the fuel water seperator and the gas switch and it seemed to run fine in the garage with the flush valve hooked up. So I took it out to the river and it ran great but after about 5 min it cut off. I cranked it right back up and rode for a little bit longer after a few times of doing this it would not crank at all it would spit and sputter like it was trying to but just would not get the fuel. Im thinking it is the fuel pump is there any way to be shure?? and do I need a 35 lph or a 65 lph?

    Thanks for the help,
    Clint


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Welcome to the Hulk

    Click on my signature for Service Manuals, and follow the second link for information specific to the Polaris Fuji engines.

  3. #3
    im having the same issue. make sure u rn't running old gas that has been sitting in there for awhile. i suggest sucking all the gas out and filling it with some quality 93 then giving it a try. could be water build up in the gas from sitting so long. at least im hoping thats whats wrong with mine lol

  4. #4
    why do motors always fight me??!
    Join Date
    Jun 2009
    Location
    rogers, arkansas
    Posts
    15
    i also just got a 780 slx and it didnt run till i primed the carbs a couple times...
    since urs ran i dont think its the pump but maybe old gas or even a stopped up line..... i removed and cleaned my tank also...it had big chunks of crap in it...definitely a problem..also remember it probably hasnt ran since at least last summer ...zimmy

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    You probably clogged your internal filters inside the carbs. Especially if you bypassed the fuel water sperator, which is also a filter.

    Hopefully you didn't damage it by running it low on fuel repeatedly.

  6. #6
    cfillingi's Avatar
    Join Date
    Jun 2009
    Location
    Molino, Florida
    Posts
    39
    where are the filters inside the carbs? i think its the fuel pump though by just the way its acting because i put a filter on the fuel return line going to the fuel pump and it wouldnt run at all which leads me to belive it is a fuel pressure issue with the pump? any ideas if this is correct?

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by cfillingi View Post
    ...I put a filter on the fuel return line going to the fuel pump...
    The fuel return line doesn't go anywhere near the fuel pump.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Quote Originally Posted by cfillingi View Post
    where are the filters inside the carbs? i think its the fuel pump though by just the way its acting because i put a filter on the fuel return line going to the fuel pump and it wouldnt run at all which leads me to belive it is a fuel pressure issue with the pump? any ideas if this is correct?
    You have a high output fuel pump on that ski already, unless someone swapped it out.

    The filters are on the back side of the carbs. The restrictor is built into the MAG carb return nipple, so putting a filter on the return was a useless test.

    Open the carbs and check the internals.

    If you feel the fuel pump is failing, then buy a rebuild kit for it, rather than a new pump. (only if it's the pentagon shaped triple outlet fuel pump)

  9. #9
    cfillingi's Avatar
    Join Date
    Jun 2009
    Location
    Molino, Florida
    Posts
    39
    i do have the 5 outlet high output pump so i plan on taking the carbs out tonight and looking at all the fuel lines i could have sworn on of thoose lines went to the pump but maybe it was just the pulse line. i downloaded the manual that K447 had so maybe that will help a little bit lol are thoose the service manuals that clymer and haynes put out??

  10. #10
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Those are Polaris manuals.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 Polaris SLX 780 circuit board
    By jfusco1246 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-26-2015, 09:29 AM
  2. Polaris sl 780 starving for fuel
    By Dmartin681 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-03-2014, 05:53 PM
  3. 96 Polaris SLX 780 No Spark
    By kimi311 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-03-2010, 06:56 PM
  4. '96 Polaris SLX 780 Runs but wont shut off, other...
    By campsmith in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-27-2010, 07:57 PM
  5. 96 polaris SLX 780 fule system
    By koryk in forum Polaris PWC Performance
    Replies: 3
    Last Post: 04-24-2009, 01:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •