Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808

    Need Diagnostic Help -- 2005 RXP

    Hey guys, my ski is acting up..doing something I haven't experienced before. It's a strange popping noise and it seems to only occur between 4000-5400 RPMs. I am also randomly down to 7300 RPMs instead of 7900-8100. It feels weak. I am wondering if this is a misfire? I am going to check the coils for cracks and swap the spark plugs. I just don't understand what it could be that it only happens in that RPM range specifically & possibly cause a loss of 6-700 RPMs. Also, my exhaust manifold bell is melting a bit and I don't understand why considering I have a RRFPR set 2# higher than most people to ensure it's not running lean (no LM-1 to test it with right now)...I'm wondering if the apparent lean condition has anything to do with the popping noise. I guess I'll have to do a compression check too. Any advice would be greatly appreciated.


  2. #2
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by JFizzleJR View Post
    Hey guys, my ski is acting up..doing something I haven't experienced before. It's a strange popping noise and it seems to only occur between 4000-5400 RPMs. I am also randomly down to 7300 RPMs instead of 7900-8100. It feels weak. I am wondering if this is a misfire? I am going to check the coils for cracks and swap the spark plugs. I just don't understand what it could be that it only happens in that RPM range specifically & possibly cause a loss of 6-700 RPMs. Also, my exhaust manifold bell is melting a bit and I don't understand why considering I have a RRFPR set 2# higher than most people to ensure it's not running lean (no LM-1 to test it with right now)...I'm wondering if the apparent lean condition has anything to do with the popping noise. I guess I'll have to do a compression check too. Any advice would be greatly appreciated.
    Bad injector?? Weak coil???

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    That was actually my first thought. I am going to check that too.

  4. #4
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Maybe some bad gas?

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    It happened near the end of the last tank of fuel yesterday and kept on going thru a new tank from a different station today. Both 93 octane and at stations that have substantial traffic...

    I forgot to mention that I pulled the charger to reset the slip moment. It wasn't bad, but I increased it. No change. I have a Rude 1, 42s, RRFPR, XS IC, 4" front air intake and get out-run by a bone stock RXP now. Last week this boat was pulling upper 70s and cracked 80 once.

  6. #6
    rxpxseadog's Avatar
    Join Date
    Sep 2008
    Location
    long way from home
    Posts
    490
    +1
    54
    I'd like to ride with you sometime, but I have no thoughts beyond the obvious - whats already been stated.



    Quote Originally Posted by JFizzleJR View Post
    It happened near the end of the last tank of fuel yesterday and kept on going thru a new tank from a different station today. Both 93 octane and at stations that have substantial traffic...

    I forgot to mention that I pulled the charger to reset the slip moment. It wasn't bad, but I increased it. No change. I have a Rude 1, 42s, RRFPR, XS IC, 4" front air intake and get out-run by a bone stock RXP now. Last week this boat was pulling upper 70s and cracked 80 once.

  7. #7
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    I only saw 1 RXP-X at the AWA ride this weekend and it was silver/blacked out .. where were you?!

  8. #8
    rxpxseadog's Avatar
    Join Date
    Sep 2008
    Location
    long way from home
    Posts
    490
    +1
    54
    Quote Originally Posted by JFizzleJR View Post
    I only saw 1 RXP-X at the AWA ride this weekend and it was silver/blacked out .. where were you?!
    I was going to PM you to let you know we weren't going to make it.

    It was too cold and the threat of rain was just too much of a deterrent.

    Let me know if you ever head south of Kingston.

  9. #9
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Quote Originally Posted by JFizzleJR View Post
    ... I guess I'll have to do a compression check...
    James, that is the next thing I would do. I hope they all check good, and you find it to be an ignition/coil problem... but I have an apprehensive feeling about #3.

  10. #10
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Sounds like ignition coil or plug problem to me.

    Check connectors to the coils & the little red silicone seal is in place too!, clean the coil and the tip, pull the plugs out and check the insulator/s are clean, and not cracked.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help,, 2005 rxp swap into a 2006 model??
    By Justino in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-03-2016, 08:40 PM
  2. Desperate need help!!! 2005 rxp & rxt
    By 2005rxp-t in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-28-2013, 06:37 PM
  3. need engine help with RXP
    By divin10 in forum 4-Tec Performance
    Replies: 10
    Last Post: 12-23-2008, 09:11 AM
  4. Need diagnostic help please
    By ecpChris in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 06-08-2008, 06:35 PM
  5. Newbie needs diagnostic help from the experts
    By patfergie44 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-12-2007, 12:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •