Page 1 of 11 1 2 3 ... LastLast
Results 1 to 10 of 107
  1. #1
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6

    Fuel pump issue need input

    Hey Guys I took my latest project out on the water for the first time today. I am have some fuel pump issues I believe. It's a 94 sl650 It runs great for about 15-20 minutes, then it will only idol. If you try to go faster it just dies. Its not getting fuel. The weird part is if I drain the fuel pump of gas it draws fuel again really well but then it just stops after about 20 minutes of riding. Idol is good but if you go full throttle for any length of time it just dies on me. Again it will start right back up but only idol. I put the triple fuel pump in it and rebuilt the pump as well. Any tips or thoughts? Thanks Mike


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    When it gives trouble, unscrew the gas cap for a few seconds to relieve vacuum, then tighten it back up. If that fixes the problem, the one-way fuel tank venting valves are stuck closed.

    Check the parts diagrams for the valve location.

    I think the 1995 models had an upgraded tank venting system, with two valves instead of one. Compare the 1994 and 1995 parts diagrams for the fuel tank.

    All the 1995 vent parts (both valves and the hose tee)are still available new, and not expensive. I listed the part numbers recently in another thread.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Have you checked the water seperator?

  4. #4
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    Thanks, I am going to order the new valves just to be safe anyways. I noticed there was no pressure in the fuel tank when I opened the gas cap, usually I can hear it on my other ski's, but this one I didn't . X, I have a water-fuel separator, not a lot going on in there. What would be an issue with it? Thanks Mike

  5. #5
    Hayabusa's Avatar
    Join Date
    Sep 2006
    Location
    Trenton Michigan
    Posts
    493
    Being I helped work on the ski, let me add a little more information. The entire fuel system from the tank to carburetors have been replaced. This includes new fuel lines, rebuilt triple outlet pump, etc. The restrictor is installed. The tank and pickup are clean as well as the fuel water separator. The pulse line is new and we double checked the clamps to make sure there was no leakage. There are no pinched fuel hoses or anything like that. The problem is not related to a venting issue with the tank. You can remove the gas cap and it does not resolve the problem.

    As Mike mentioned, the ski runs fantastic for about 20 minutes before it starts to bog. At that point, if you observe the fuel lines, very little if any gas will be seen pumping. The only thing that temporarily resolves the problem is to remove and reinstall the fuel pump. I know that seems weird, but it's a fact. We dismantled the pump and could not find anything wrong with the rebuild or the parts used for the rebuild. This is not our first pump rebuild so we're very sure it was put back together correctly. In spite of that, we are going to rebuild the pump again as soon as we get a new rebuild kit.

    Any thoughts would be greatly appreciated.

    Thanks...Gary

  6. #6

    Join Date
    Jul 2007
    Location
    Alabama Gulf Coast
    Posts
    206
    Make sure your in line fuel filters are not clogged also. This was one of my issues.

  7. #7
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    The lows on the carbs are set to factory and the highs are an 1\8 rich ' what's odd is at first the pump works great then it just stops punping after a high speed run and will only idol from there. Thanks for any help. Mike

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by xlint89 View Post
    Have you checked the water seperator?
    Was wondering if the filter inside the water sperator was clogged if you have the better 1 of the 2.

  9. #9
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    I don't have any filter in my separator, there's actually nothing in there at all just an open cup. I took apart the fuel pump and replaced the rubber seats again and it seems to work better but it still bogs down going around a sharp turn and i'm still not getting top speed out of it, you can feel the gas kicking on and off at high rpm almost like its pulsing a little.

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Is the fuel tank venting?? As mentioned above.

Page 1 of 11 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gp1200 fuel pump issues and solutions... long.
    By the_natrix in forum Yamaha Old School Skis
    Replies: 38
    Last Post: 11-11-2017, 11:37 PM
  2. Fuel / electrical issue need help
    By Palm Beach Punisher in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-13-2010, 03:19 PM
  3. gp1200 fuel pump issues and solutions... long.
    By the_natrix in forum Yamaha PWC Performance (2-stroke)
    Replies: 27
    Last Post: 06-20-2009, 12:58 AM
  4. 04 Gp1300r Fuel Pump Picture Needed
    By gzk in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 01-01-2009, 09:39 PM
  5. kawasaki 900 zxi fuel pump issue?
    By philsmtech in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 07-13-2008, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •