Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109

    Genesis starts and dies

    2001 Genesis I, starts when throttle at 1/2, idles but rough then dies, lots of smoke......just off to get compression tester. Where or what is the best place to start. I am also going to replace all the oil lines as suggested.....


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Check the mechanical health of the engine, of course.

    If it all seems correct, then we can get into the diagnostics more deeply.

    Click here for the Service manual.

  3. #3

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    of course finding a compression gauge is proving to be some what more difficult being as where I live, what else can I do to check the mechanical condition. Apparently it was thought the computer might be bad....I put the original one back in as to start from scratch for diagnosis....I have another emm and matching injectors.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by jukican View Post
    of course finding a compression gauge is proving to be some what more difficult being as where I live, what else can I do to check the mechanical condition. Apparently it was thought the computer might be bad....I put the original one back in as to start from scratch for diagnosis....I have another emm and matching injectors.
    Talk to any automotive or truck service location. They will all have compression gauges.

    Talk to your neighbors - lots of folks tend to have one hanging up in the garage or workshop...

  5. #5

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    Front cyl 135
    middle 135
    back/rear 90

    Looks like it time to pull the head and cylinder.....
    Last edited by jukican; 06-16-2009 at 02:45 PM. Reason: just adding to post

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by jukican View Post
    Front cyl 135
    middle 135
    back/rear 90

    Looks like it time to pull the head and cylinder.....
    Depending on what you find, there may be a separate issue with the fuel system or electrical.

    But get the mechanical stuff diagnosed first.

  7. #7

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    I had a friend suggest to put some oil in the cylinder and retest for pressure, said it could be dry rings......will try it then try see about removing the cylinder.

  8. #8

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    So I put a little 2 stroke oil in the cylinder, compression came up to 135, then dropped 125 next round then to 115 on the 3rd try..Time to pull the head and Cylinder????

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by jukican View Post
    ...Time to pull the head and Cylinder????
    Yep.

  10. #10

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    I removed the rear cylinder, the one with the low compression. First, there is no doubt it is running rich, seem to be wet oil in the exhaust holes, oil dripped from the exhaust when I remove the manifold. The cylinder is scored on the intake side, I have a few photos
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	assorted 502.JPG 
Views:	29 
Size:	835.2 KB 
ID:	137744   Click image for larger version. 

Name:	assorted 501.JPG 
Views:	32 
Size:	847.0 KB 
ID:	137745   Click image for larger version. 

Name:	assorted 500.JPG 
Views:	33 
Size:	901.2 KB 
ID:	137746  

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 XP-DI starts and dies....
    By jtskier11 in forum 2-Stroke Performance
    Replies: 19
    Last Post: 01-12-2016, 02:11 PM
  2. 91 300sx problem; starts and dies
    By d12jdm in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-21-2014, 09:14 AM
  3. 1999 Genesis Ficht will start and idle but dies when throttled up
    By Grumsey in forum Polaris Open Discussion
    Replies: 27
    Last Post: 04-28-2014, 11:45 PM
  4. Starts and dies
    By SHOBiz in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-11-2011, 08:10 PM
  5. Intermittent no start and random "dying" out of nowhere.. XP 800..
    By javiert99 in forum 2-Stroke Performance
    Replies: 19
    Last Post: 07-12-2007, 11:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •