Results 1 to 5 of 5
  1. #1
    Nickeljet's Avatar
    Join Date
    Feb 2007
    Location
    Moss Bluff Louisiana
    Posts
    301
    +1
    2

    05 GTX supercharged won't run

    I have a 2005 supercharged GTX. It idles very poorly and dies as soon as you give it any throttle. Sometimes it backfires. I have drained and replaced the fuel and checked the filter. Any ideas or input would be greatly appreciated


  2. #2

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    How's the battery ?

    Ours started running poorly. I changed the plugs, gas-- nothing. They would start without a hitch-- but wouldnt run.

    Replaced the battery-- vollla !

    It was explained to me that the charging system did just that-- charge. It wasnt enough juice to actually run the engine w/o a good battery.

    Mabye that's it ???

  3. #3
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Be careful, a backfire can split the plastic intake manifold. Matbe you should check it for leaks... Ron

  4. #4
    Nickeljet's Avatar
    Join Date
    Feb 2007
    Location
    Moss Bluff Louisiana
    Posts
    301
    +1
    2

    Found it

    This ski only has 25 hrs on it and the plugs were fouled. WOW!! sure doesn't get much plug life.

  5. #5

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Guy at the dealer commented about plugs- Said "Why do you think they have a spare plug carrier built in the rear seat tray ?" I guess he sees thata lot *shrugs*

    We've not had problems with plugs.....yet.... I do change them at the first of each season. We typically get 60 or hrs a season.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 185 GTX Supercharged battery being run down
    By joseph9936 in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-19-2016, 08:56 PM
  2. 2002 GTX DI won't run above idle in water
    By zone 5 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-26-2007, 06:53 PM
  3. 03 GTX SC won't stay running
    By INSMAN in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-14-2007, 03:07 PM
  4. 05 Stage 3 Riva Won't Run
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 18
    Last Post: 04-30-2007, 12:08 PM
  5. '05 GTX Limited Running Terrible
    By rto in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-11-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •