Results 1 to 2 of 2
  1. #1

    96 gsx charging problem

    ok so after about an hour of running the battery dies and wont start. i checked the volts at the battery and was getting 12 volts when not running and 10.5 when running so i think it is my rectifier got a used one from someone here hooked it up and same thing 12 volt not running and 10.5 running i checked the fuses in the comp box and they are all good . anyone with any help would be great. \
    thanks rob


  2. #2
    planiack's Avatar
    Join Date
    Apr 2009
    Location
    Punta Gorda
    Posts
    181
    Quote Originally Posted by lostinilm View Post
    ok so after about an hour of running the battery dies and wont start. i checked the volts at the battery and was getting 12 volts when not running and 10.5 when running so i think it is my rectifier got a used one from someone here hooked it up and same thing 12 volt not running and 10.5 running i checked the fuses in the comp box and they are all good . anyone with any help would be great. \
    thanks rob
    Unplug the rectifier. Connect an ohm meter between two of the Yellow wires. The resistance should be about 1.0 ohms. Do that with the other 2 combinations of yellow wires, again about 1.0 ohms. Connect the ohm meter between a good ground and each of the yellow wires. You should have infinite resistance. Next, set you volt meter to read AC voltage. Hook the meter between 2 of the yellow wires and start the ski. Increase the RPM to 3000. You should read more than 20 VAC. Do that with the other 2 combinations of the yellow wires. Next, hook a voltmeter to the red wire and to a good ground. Make sure that you have battery voltage. Last, make sure that the rectifier housing is grounded good. Hook your voltmeter positive lead to the battery and the ground lead to the rectifier housing. You should have battery voltage. If all of those tests tests pass, the rectifier assembly is to blame and if one or more of those tests fail, the magneto or wiring is at fault.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 GSX Starting problem
    By barondurden in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-24-2013, 06:45 PM
  2. Please Help 96 zxi charging problems
    By mogyver69 in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 05-12-2011, 12:18 AM
  3. 96 gsx 787 with a problem..
    By nick34 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-29-2010, 09:48 AM
  4. 96 gsx charging problem
    By lostinilm in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-06-2009, 05:45 AM
  5. Charging system 96 GSX 787 engine
    By rivermann50 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-24-2009, 07:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •