Results 1 to 7 of 7
  1. #1

    need help please!

    hey guys, so ive only had my 01 gp800r for about 3 weeks now and last week when i went out i filled up completely, and my meter was working at the time. within a couple hours the gas meter was low so i put in a couple bucks but i noticed it didnt go up at all. i figured maybe i was low on oil? but when i filled up with oil the meter still didnt go up. im guessing my guage is broken but im not sure. does anyone have any suggestions?


  2. #2
    sharkriver's Avatar
    Join Date
    Dec 2007
    Location
    Wall N.J.
    Posts
    174
    a couple of bucks at todays gas prices might not make the gas gauge move it is a 16 gallon tank!

  3. #3
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    yea you'll need to put more than 3/4 gallon in to see a difference

  4. #4
    yz450f's Avatar
    Join Date
    Aug 2008
    Location
    Long Island NY
    Posts
    657
    +1
    6
    by me it usuallu takes ten gallons everytime and still has room for more

  5. #5
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    idk about the 800 but the 1300 gas level says empty when it still has about 6 gallons left. i adjusted mine to be more accurate... i dont go far from my ramp usually.

  6. #6
    gp1200rrk's Avatar
    Join Date
    Apr 2009
    Location
    Macungie, PA
    Posts
    88
    fill it up completely and see what it says

  7. #7
    gp1200rrk's Avatar
    Join Date
    Apr 2009
    Location
    Macungie, PA
    Posts
    88
    another thing to look at when it comes to gauges and sending units, is the ground

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new to polaris need help please
    By pepp101 in forum Polaris Projects
    Replies: 22
    Last Post: 07-30-2007, 02:15 PM
  2. 96 SL900 Uh Oh Need HELP Please
    By christian79 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-16-2007, 11:58 PM
  3. Need Help Please!!!!!! On Prop Choice
    By MB VIP in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-10-2007, 08:41 AM
  4. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  5. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •