Results 1 to 7 of 7
  1. #1

    Join Date
    Jun 2009
    Location
    Hartwell, GA
    Posts
    2

    Polaris 1050 SLXH will not crank.

    Polaris 1050 SLXH 98
    Bought this ski last week. Tested on lake and ran well, but battery was weak and needed replacing.

    I put a new battery in it today, and when I hooked it up, the bilge pump came on and runs constantly. When I checked to see if it would crank, the starter seems to be spinning free, and the digital display shows nothing.

    Have I missed something? Is there something I need to do after replacing battery? I do not have a manual for it yet.

    Any help is appreciated.
    Last edited by Soulraptor; 06-20-2009 at 12:25 PM. Reason: Left of model year


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,273
    Welcome to the Hulk

    Click on my signature for manuals, and other useful info.

    Did you by any chance connect the battery polarity backwards?
    Red is positive, Black is negative

  3. #3

    Join Date
    Jun 2009
    Location
    Hartwell, GA
    Posts
    2

    Red face

    That question is about as bad as "do you have gas in the tank" when something won't start.......unfortunately for me, that is exactly what the problem was.

    Thanks for slapping me back into reality. I automatically went into stress mode without checking basics first.

    Thanks for bailing me out. I am the idiot for the day!

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,273
    Quote Originally Posted by Soulraptor View Post
    That question is about as bad as "do you have gas in the tank" when something won't start.......unfortunately for me, that is exactly what the problem was.

    Thanks for slapping me back into reality. I automatically went into stress mode without checking basics first.

    Thanks for bailing me out. I am the idiot for the day!
    You are not the first to do this, by a long shot

    Now you need to check if anything has been damaged.

    Check the fuses inside the electrical box, if either the MFD or the bilge pump is not working. Only replace the fuses with the correct sizes;
    1/4 Amp and 3 Amp

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Welcome to the hulk..

    We all have been down the idiot for the day road..

  6. #6
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Quote Originally Posted by Soulraptor View Post
    That question is about as bad as "do you have gas in the tank" when something won't start.......unfortunately for me, that is exactly what the problem was.

    Thanks for slapping me back into reality. I automatically went into stress mode without checking basics first.

    Thanks for bailing me out. I am the idiot for the day!
    Welcome to Green Hulk.

    You have some competition for the Idiot hat ! You better rest up,I'm gonna kick your A$$.

    I hope the rest is good.

  7. #7

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by casey67 View Post
    Welcome to Green Hulk.

    You have some competition for the Idiot hat ! You better rest up,I'm gonna kick your A$$.

    I hope the rest is good.

    i see someone is up past there bed time

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Virage 2000 750 will not crank the starter
    By msj in forum Polaris PWC Performance
    Replies: 1
    Last Post: 07-05-2015, 09:58 PM
  2. 2002 Polaris Freedom Engin Light flashing and will not crank
    By snackcakes97 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-16-2011, 05:38 PM
  3. 2002 Polaris Virage i will not crank
    By mammalhead in forum Polaris Open Discussion
    Replies: 24
    Last Post: 06-09-2011, 01:44 PM
  4. 2000 Polaris Genesis FFI will not turn over
    By maui in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 04-10-2008, 08:24 AM
  5. 98 XPL will not crank
    By Skripo in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-03-2007, 09:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •