Page 1 of 9 1 2 3 ... LastLast
Results 1 to 10 of 83
  1. #1
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3

    High Idle After Flipping Ski and Taking on Some Salt Water

    I flipped my ski a few weeks ago and took on some saltwater. No saltwater got in my engine or in the oil. I rinsed the inside out and cleaned everything off. My ski had an idle of about 1700-1800 rpm. I changed my plugs today and the problem persisted. Is there anything I should check for?


  2. #2
    hilomikey's Avatar
    Join Date
    Apr 2007
    Location
    Hilo Hawaii
    Posts
    482
    Check to see if bolt for removing water from intake manifold is loose or gone

  3. #3
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    I'm not exactly sure where that is. Any pics?

  4. #4
    hilomikey's Avatar
    Join Date
    Apr 2007
    Location
    Hilo Hawaii
    Posts
    482
    HMMM Don't have pic but it is right under incoming fuel line from gas tank to fuel rail. Behind the oil dipstick on intake manifold. Hope this helps.

  5. #5
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    Wow. I just started to check my oil catch cans and both are filled with a white greasy substance. I'm guessing its oil and water??? I cleaned both out. I took all of my filters out and cleaned them. It also appears that oil got in the intercooler. That is out but I won't be flushing it till tomorrow. I checked my oil dipstick and the oil is clear, but when I took the cap off on top, I saw that there was a tiny bit of white gunk up top, but not much. I will change the oil a few times tomorrow to try to fix that up. also cleaned up the rubber pieces that had white gunk in it. Damn that was a mess. I'll finish up tomorrow and let you know what the outcome is.

  6. #6
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    I read skips blog about this and I was doing the right things but I do have one problem. My catch cans are gunked up and I only rinsed them with hot water. He said you should use a parts washer. Do I have to go to a mechanic to get this or is this something that I can do on my own?

  7. #7
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    Quote Originally Posted by hilomikey View Post
    Check to see if bolt for removing water from intake manifold is loose or gone
    I checked this and it is still there

  8. #8
    dawson's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA
    Posts
    525
    salt water has probabley seized the idle control motor and it is locked in place.

    does it still maked the strong ticking noise when you turn the ski on and off or just a dull one ?

  9. #9
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    It seemed to be about the same. If it is seized, where is it and is there anything I can do to fix it or do I need a new one?

  10. #10
    dawson's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA
    Posts
    525
    its the little black thing sitting on top of the throttle body

Page 1 of 9 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris jet ski taking on too much water
    By april in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-16-2011, 07:57 AM
  2. 2004 rxp 10 hours after rebuild 7700rpm and 70mph on speedo
    By jtrudel90 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-15-2011, 04:41 PM
  3. XLT1200 has high idle after rebuilding
    By Steveard in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-29-2011, 05:53 PM
  4. NEW SEA DOO Skis and Boats on sale
    By NCRXP in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-23-2010, 12:38 PM
  5. High Idle After it runs a while
    By retro in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-14-2009, 06:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •