Results 1 to 5 of 5
  1. #1
    2008 RXT outonalimb's Avatar
    Join Date
    Jun 2009
    Ct and NH

    Made the first run 2day

    I picked a 2008 rxt 215 W/trailer two life jackets OTD 10,500. I got talked into going out this morning with my son and daughter. The conditions were 70 very cloudy w/light rain. At the 2hr marker my daughter said, she gota need for speed. I said let try a speed run, Wacked the throtle for 10 seconds wide open. The speedo read 71, The gps clocked top speed 68.6mph. Now that is with 3/4 tankof fuel and four hundred lbs of riders. I pretty happy. Does this sound like it is the norm or should it be better?

  2. #2
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Southern California
    Sounds great!

  3. #3
    That`s really nice!!
    Did you finish the 10Hours with learning key? or this is used one?

    BTW - Are you doing the running in with the learning key?

  4. #4
    2008 RXT outonalimb's Avatar
    Join Date
    Jun 2009
    Ct and NH
    idan, I bought this brand new in the box. Leftover, zero mileage. I am not useing LK. I was easy on it for 2 hours, now I will open it up but not for more then 10 seconds...

  5. #5
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Jacksonville, N.C.
    Don't use the learner key for breakin. It has been posted on here that the learner key limits speed by cutting ignition to 1 cylinder. Don't know if it's true or not but just use the regular key and limit speed with your thumb or finger.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. First run of the season almost sank
    By JGRXP in forum 4-Tec Performance
    Replies: 124
    Last Post: 05-02-2013, 04:07 AM
  2. Little help after the first run please..
    By Urwheelman in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-07-2012, 04:25 PM
  3. GP760 runs great for the first two minutes...
    By 1579 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-12-2010, 08:10 AM
  4. Gonna be taking out the SL780 for its first run after rebuild...
    By hyoctane23 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 03-11-2008, 09:06 AM
  5. Made my first run on RXP... bad news
    By konabiker47 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-08-2007, 11:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts