Results 1 to 10 of 10
  1. #1

    trying to narrow down the problem

    so ive been battling this oil leak problem for a while, ive talked to many people and all have been a good help, and all have had different opinions, so ive been trying to narrow the problem down 1 by 1 becasue money is tight right now for the ski to sit in a shop while they diagnos the problem

    ive been putting a quart of oil everyother trip out on the ski. at first i thought there was a major leak but it turned out the oil cap wasnt on. im an idiot so i put that back on thoguht nothing of it. oil light came on again week later thought it had to do with the bov, someone said they suck and cause problems so i took it off. same problem. then i changed the s/c washers thinking maybe it was slipping or it was going and caused a problem in the oil pump, nothing still have same prob. then i got the catch can from riva thinking maybe oil was getting into the intake and i was burning it somehow out the exhaust. nothing again its actually empty. now im noticing oil in the hull like a sludge at it seems to be around the whole battery area has anyone seen any problems, leaks, cracks or anything there? i also thoguht maybe an o-ring when i did oil change but theres no oil to the back of the ski so i kinda ruled that out

    so theres my story in a nutshell i really want to bring to a mechanic but i kinda wanna use that as a last resort because of my budget

    any help would be great thanks


  2. #2
    Ziggy's Avatar
    Join Date
    Feb 2006
    Location
    NE Ohio
    Posts
    1,150
    +1
    3
    Invest a couple of bucks in an inspection mirror at an autoparts store. Use this and a flashlight to inspect around the engine.

  3. #3
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    is the crankcase breather hose still on??
    where is it going to??
    an oily film can be from crankcase fumes spewing fuel oil gasses into the hull.
    but not 1 qt. a week...
    i'm no expert, but in a dry sump sytem doesnt the oil cap have to be on?? or oil will not pressurize properly, and or blow out the oil cap??
    if you lost oil pressure,, the cylinders could be scorched /rings shot, and that is where all you oil is going
    does the ski smoke alot??

  4. #4
    Quote Originally Posted by lextoy View Post
    is the crankcase breather hose still on??
    where is it going to??
    an oily film can be from crankcase fumes spewing fuel oil gasses into the hull.
    but not 1 qt. a week...
    i'm no expert, but in a dry sump sytem doesnt the oil cap have to be on?? or oil will not pressurize properly, and or blow out the oil cap??
    if you lost oil pressure,, the cylinders could be scorched /rings shot, and that is where all you oil is going
    does the ski smoke alot??
    the crankcase hose goes to the riva catch can

  5. #5
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Probably need to do a compression and leakdown test to make sure you don't have a lot of blow by.

  6. #6
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    I found an oil leak on a buddy's rxp right at the driveshaft where it enters into the back of the block. Problem was you had to have the motor running and peek under the protective black rubber shield at the same time!!!!! It was a slow drip that would stop when you shut down and go when you took off.

    Check that one out. It was a one-in -a million-find!!!!!!!

    Brendan

  7. #7
    piper250's Avatar
    Join Date
    Sep 2006
    Location
    Claytor Lake, Dublin Va.
    Posts
    94

    oil leak

    I had a mystery oil leak once and found that the oil cooler was leaking. Look around there as well.

  8. #8
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34
    BDNJ was it the bearing or the boot? having the same problem

  9. #9
    i think my problem is at the front of my motor thats where i seem to find the oil

  10. #10
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    Quote Originally Posted by IBADTON View Post
    BDNJ was it the bearing or the boot? having the same problem
    I called PPG in Florida and ordered the entire assembly new. New shield and new bearing carrier. Personally, I think it was the the way the bearing carrier seated in the black rubber housing. You need to use laquer thinner to clean any grease/oil and make sure the carrier is fully seated and clamped down evenly all the way around.

    Starting new worked for me, but might not have been necessary looking back.

    Brendan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new to site trying to figure out this problem!
    By barkleyz in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-25-2014, 08:49 PM
  2. some people need to put down the crack pipe, craigslist funny
    By WBoulton in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-30-2011, 09:34 AM
  3. 2007 F12x - Is it possible to turn down the idle?
    By barmanvarn in forum Honda How To & FAQs
    Replies: 4
    Last Post: 11-23-2010, 12:14 PM
  4. wondering if it's going to be a problem down the road
    By JIM'S PERFORMANCE in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-14-2009, 05:48 PM
  5. Help Me Narrow Down The Issue's With The Gibson
    By hydrojunkie in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-07-2008, 03:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •