Results 1 to 2 of 2
  1. #1
    why do motors always fight me??!
    Join Date
    Jun 2009
    rogers, arkansas

    Question MFD cuts off while running 780 slx

    my MFD occasionally flickers and turns off for a few seconds...
    during that time the ski runs bad and kinda sputters, then it comes
    back on and all is fine. any idea whats going on here?
    its only done it maybe 2 or 3 times out of a couple days riding ...
    otherwise, im having a blast on it! thx..zimmy

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    I'd say you have a bad elec connection.

    Check your ground wire.

    Check your battery cables.

    Open the elc box and check the grounding screws are tight inside.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1200r cut off while riding. Starts fine/compression good
    By fivespeedsteed in forum Yamaha PWC Performance (2-stroke)
    Replies: 56
    Last Post: 10-27-2012, 09:05 AM
  2. Replies: 2
    Last Post: 09-16-2011, 08:39 AM
  3. Cuts off while moving ~ looking for help
    By Horus in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-25-2011, 04:13 AM
  4. gp1200r running fine then cut off while riding
    By 00gprNC in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-04-2009, 04:45 PM
  5. Ski cut off with hose running
    By super_gtx in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2008, 04:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts