Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: Photo happy

  1. #1
    Appologizes for the last user title katz1002's Avatar
    Join Date
    Jun 2009
    Location
    Sadler
    Posts
    317

    Photo happy

    http://photobucket.com/katz1002 look and tell me whats wrong

    is there a tee in one of the lines from the tank?
    whats with the rust should i be worried?
    it there suppose to be three pickup tubes in the tank or just the main/res?
    tell me more.

    thanks,
    Katz


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Pics are pretty fuzzy.

    A tee from which tank?

    Rust was where?

    Yes, just main and reserve go into the fuel.

    Return hose

    Vent hose

  3. #3
    pics are fuzzy, the reeds if there not chipped should be good but if you got them out I myself would replace them.. A good coat of plastic or vinyl paint should bring that handle bar pad back to life.. I just seen the other picture with the broken reed replace them all..

    How about a what year of Polaris you have and size 650, 700. 750 history about your ski was it running when did it stop running and so forth, you dont wanna sink allot until you know what you may be dealing with.. Cya Slick

  4. #4
    Now I know you you are and your 650, if I where you I would search craigs list and find your self another 650 and scavenge parts for one for the other and make your self a good running ski.. That one picture of the oil water gas mix on top of your pistons looked like a ice cap from Tim hortons, find your self another ski and scavenge it may cost you less if your on a budget to get this up and running.. Cya Slick

  5. #5
    Appologizes for the last user title katz1002's Avatar
    Join Date
    Jun 2009
    Location
    Sadler
    Posts
    317
    sorry there fuzzy fro the fuel tank theres a tee in one of the fuel lines and the rust thats a pic of the crank from the carb oppening and whats with the red cap above the oil feed on the intake

  6. #6
    whens the last time it ran?

  7. #7
    Appologizes for the last user title katz1002's Avatar
    Join Date
    Jun 2009
    Location
    Sadler
    Posts
    317
    The last time the ski was run was 2 years ago i cant find another polaris well even a motor on cragslist and ebay. i belive the motor was sunk or turned over the wrong way how would that much water get in there?


    I got the ski for free so i guess i had to sink money into it somewhere and im low on funds because im only 15 i have my own buissness and am bringing in enough for some parts.

    ive got a new tripple output fuel pump also new lines they havent arived im getting many parts from John Z. (reed cage, top end kit, complete gasket set)

    i plan on not putting new gaskets in until later the topend can wait the new reeds are going on but its getting re assembled and ridden until it croaks again then its going into the project fourm and im getting the motor out carried upstairs into my room and rebuillt over the weeks. done


    Thanks,
    Clayton

  8. #8
    there is a old one on Ebay near me let me get the link for you.. Cya Slick

  9. #9

  10. #10
    Appologizes for the last user title katz1002's Avatar
    Join Date
    Jun 2009
    Location
    Sadler
    Posts
    317
    My father would kill me if i brought another ski home i had to SNEEK the one i got into the garage we used to have a polaris until my dad sold it because he thought it "went to fast" but hey at least they care

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upload Photos!
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-02-2005, 09:34 PM
  2. Upload Photos!
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-17-2005, 09:31 AM
  3. First time out with stage 1 05 RXP Not happy.
    By Fastcat in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-10-2005, 09:03 PM
  4. Photo album is up!
    By MikeTrin in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-10-2005, 09:44 AM
  5. weekend results I'm happy
    By watermedic in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-09-2005, 06:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •