Results 1 to 2 of 2
  1. #1

    Yamaha GP1300 Problem

    I have an 04 GP 1300 R been working fine i use it on salt water but dont use salt way to flsuh today started the jetski in the water and it was making a weirddddd loud noise like the engine was kinda stuck and wouldnt accelerate for like 30s it was making the loudest engine noice ever after the 30 s it was great worked fine and i m in west africa and dont have no yamaha dealership around so if somebody has any idea about what that noise could be no check engine on

  2. #2
    Mike xsockguyx's Avatar
    Join Date
    Sep 2007
    Check compression on your cylinders, check the pump to see if anything was sucked in. Do you have any mods??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha GP800R problem accelerating
    By FLWaverunner in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 10-17-2011, 10:20 PM
  2. '02 yamaha gp1200R problem
    By xxFNGxx in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 06-20-2010, 04:30 PM
  3. 03 gp1300 problem
    By ctct2118 in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 08-24-2009, 07:37 PM
  4. Yamaha GP1300R problem
    By thierdiop in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-21-2009, 06:14 PM
  5. Yamaha engine problem
    By surfside650 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 08-05-2007, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts