Results 1 to 3 of 3
  1. #1

    Dealer overfilled Oil... Lose top speed?

    Just a quick question or two here... I just got my RXT-X back from the dealer for it's 10 hour service and surprise surprise they overfilled the oil. I checked it after running for a bit, and it is reading about a half inch over the top bent line of the dipstick.

    I ran it from the boat launch to the dock and it is still hitting 8140rpms at wot. Do you think it is affecting my top speed being quite a bit overfilled? It seems to me it is, but is the general consensus it should be right in the middle of the bends or higher to the top?

    No excess smoke or anything...

    Needless to say I called and yelled at them... What do ya think?


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Anywere between half and the top bend is were it should be run..IF it is a half inch over the top bend then pull some out and recheck it..

  3. #3
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    Quote Originally Posted by Mikey View Post
    Just a quick question or two here... I just got my RXT-X back from the dealer for it's 10 hour service and surprise surprise they overfilled the oil. I checked it after running for a bit, and it is reading about a half inch over the top bent line of the dipstick.

    I ran it from the boat launch to the dock and it is still hitting 8140rpms at wot. Do you think it is affecting my top speed being quite a bit overfilled? It seems to me it is, but is the general consensus it should be right in the middle of the bends or higher to the top?

    No excess smoke or anything...

    Needless to say I called and yelled at them... What do ya think?
    An RXT-X running 8140 RPMS with the oil lightly over the to bend? The sweet spot for the Xs is around 8000 RPM. You may want to get your oil in the middle of the bends first, then recheck your top speed RPMS.

    Ed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. extra oil killed my top speed!!
    By 1fast04neon in forum 4-Tec Performance
    Replies: 21
    Last Post: 05-05-2013, 01:28 AM
  2. 2002 Polaris Genesis is losing 1000 RPM at top speed now and then
    By travis ingram in forum Polaris Open Discussion
    Replies: 20
    Last Post: 09-06-2012, 10:58 AM
  3. 2007 ultra lx losing top speed
    By jonyv1 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-27-2012, 09:28 AM
  4. Low top speed and oil in hull
    By xray328 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-05-2012, 05:57 PM
  5. Add D Plate and lose top speed?
    By emcewin in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-17-2007, 05:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •