Results 1 to 3 of 3

Thread: 96 slt780 MFD

  1. #1

    96 slt780 MFD

    please help locate the thread to fix a mfd. I searched and searched and cant find it. I know it was here somewhere......Took the ski out the other day and everything was working great but by the end of my run(about an hour, just doing a little tuning) the multi function dispplay quit on me . HELP ME PLEASE!!!!!!!!!!! seems if its not one thing its another with these things......Thanks in advance guys


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Here you go.
    http://polarispwcknowledge.shorturl....nction-display

    Try using the search function.

  3. #3

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mfd 96 slt780 issues
    By timbo2 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-21-2015, 04:46 AM
  2. WTB grey "MODE" button for 96 780 mfd
    By mikerosi in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-22-2008, 08:35 AM
  3. 96 slt780 having problems.
    By twometal in forum Polaris PWC Performance
    Replies: 3
    Last Post: 08-11-2007, 06:29 PM
  4. Correct plug and what does the idle set at on a 96 slt780
    By gvnitup in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-06-2007, 10:16 AM
  5. 96 SLT780 general questions
    By r8333b in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-19-2007, 11:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •