Results 1 to 4 of 4
  1. #1

    Warning light flashes

    I have a 04 Yamaha Gp1300r With the riva racing upgrade in it. when i drive the Engine and overheat light comes on about once every hour. I turn the ski off and then it starts up and is fine. The engine does not smell or even feel hot . I know a lot of people are saying about d chips and heat sensors but i dont want to buy something if im not sure what it is. ANY suggestions


    Thanx everyone


  2. #2
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20
    Quote Originally Posted by brianf40us View Post
    I have a 04 Yamaha Gp1300r With the riva racing upgrade in it. when i drive the Engine and overheat light comes on about once every hour. I turn the ski off and then it starts up and is fine. The engine does not smell or even feel hot . I know a lot of people are saying about d chips and heat sensors but i dont want to buy something if im not sure what it is. ANY suggestions


    Thanx everyone
    Welcome to GH!

    Lets start out simple.... What upgrades do you have? More specifically does your ski have a dplate on it? Also is the exhaust temp sensor still attached and plugged into the side of electronics? If yes, then you need a resistor chip or you can just use a resistor to trick the computer.

  3. #3
    The ski is stock from the factory with the Riva i did not do anything to it. It is the limited edition and im not sure if it has a plate or not and also where would the exhaust sensor be attached too.

    Thanx for your help im trying to learn how to work on these skis so be as simple as you can. I DUMB hahahahahahaaha


    Thanx

  4. #4

    Join Date
    May 2006
    Location
    Orange Park, FL
    Posts
    23
    Probably has a D-Plate...

    The temp sensor is in the exhaust, on top...towards the rear. 2 wire plug.

    See if it's still connected...if so, then wire in a resistor, OR buy a 'temp chip'.

    - brian

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warning light flashes above 5000 RPM
    By jrobinsonchicago in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-14-2016, 05:50 PM
  2. Warning light flashing
    By 05 green gp in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 06-18-2015, 01:48 PM
  3. 2000 Yamaha gp1200r warning light an odometer flashing two lines -- rpms work fine
    By Groundprecision in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-13-2014, 10:55 PM
  4. polaris msx 150 warning light flashing
    By simmy in forum MSX/Matrix
    Replies: 4
    Last Post: 04-13-2012, 02:43 PM
  5. warning light flashing...HELP
    By alex_baker202 in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-09-2010, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •