Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    premix question help please

    what should the ratio be for a stock xlt 1200 01. and all to do is to pull the oil pump off and cap it and the oil lines on the carbs am i right


  2. #2

    Join Date
    Aug 2007
    Location
    Bridgeton nj
    Posts
    111
    why do you want to remove injection pump for? on stock carbs you have to rejet first before you go premix, the stock carb setting are lean from factory, I dont think if you go pemix with the factory carb settings the motor will get enough oil, If you have a good injection pump, cable and good secure oil lines on a stock ski stay with injection with Yamalube oil, the main problem on these skis are carbs, bad gas and not using the correct oil, you should premix 32-1 to 40-1 if you have correct carb setting on a PV motor,

  3. #3
    Visit cajundude.com and click on the Jet ski page. Here you will find detailed instructions on this oil pump block off kit. I have never heard of having to change the jets when doing the block off. I haven't done it on mine...

  4. #4

    Join Date
    Apr 2009
    Location
    Camano Island, wa
    Posts
    9

    Question

    Quote Originally Posted by paulie1959 View Post
    why do you want to remove injection pump for? on stock carbs you have to rejet first before you go premix, the stock carb setting are lean from factory, I dont think if you go pemix with the factory carb settings the motor will get enough oil, If you have a good injection pump, cable and good secure oil lines on a stock ski stay with injection with Yamalube oil, the main problem on these skis are carbs, bad gas and not using the correct oil, you should premix 32-1 to 40-1 if you have correct carb setting on a PV motor,
    I'm wanting to go premix on my GP1200. Does everyone agree the carbs need rejetted for the engine to run right? Member "GP 1200 R" said he didn't have to rejet the carbs.

  5. #5
    hawkrdr's Avatar
    Join Date
    May 2007
    Location
    Fleming Island/Orange Park FL
    Posts
    131
    Unless you are taking the Accel pump off and/or putting aftermarket F/A's on, I do not think there is any need to re-jet.

  6. #6
    Mike xsockguyx's Avatar
    Join Date
    Sep 2007
    Location
    NJ
    Posts
    1,744
    +1
    2
    40:1 is fine

  7. #7

    Join Date
    Aug 2007
    Location
    Bridgeton nj
    Posts
    111
    somebody should start a poll about seizing a Power valve motor with stock jetting, premix and seizing a PV motor using injection pump. Ive seized twice using stock jetting premixing both times within 20hr and not at WOT, at 1/4 throttle, and one top end bearing failure using stock jetting, oil injection at 1/2 throttle in 2ft seas pump unhooking with 185hr, I'm running premix now (I'm not using stock jetting) because I have pump cable issues, I saw my pump cable was frayed so I just unbolted pump, wire tied pump to the tank strap, put a home made plate on, hooked my tiny tack up and set my HS adj. and went with premix at 32-1, as soon as I get a cable and the time (probably this winter) I'm going back to the oil pump, I use the oil pump plus I put 1/2oz to the gal. premix, I'm not an expert but I wood like to see a pole about seizing and what setup, hours and RPM were being used.
    Last edited by paulie1959; 06-28-2009 at 06:59 PM.

  8. #8
    thanks guys for the help put the block off on it didn't do anything with the carbs mixed it 32;1 the first tank because of new motor and 40;1 the next tank carbs were fine no jetting no nothing. and the reason for taking it off on a atock ski is beacause done lost to oil line in a year and a half tired of building motors thanks

  9. #9
    espritonsevas's Avatar
    Join Date
    Dec 2007
    Location
    Miami,Fl.
    Posts
    388
    I think we need the guru Osidebill to come in here, and give his thoughts. I think he will give the best answer by far as its what he does alot.

  10. #10

    Join Date
    Apr 2009
    Location
    Camano Island, wa
    Posts
    9
    After going to premix, i'm getting a low oil warning light since i have drained the oil tank. anyone know how to wire up the oil quanity float to make the computer think the oil level is ok?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 04-01-2012, 11:26 PM
  2. Impeller pitch question! Help please!!
    By H20chick in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 09-21-2010, 04:49 PM
  3. 98 GS Questions, Help please!
    By ultra150JCT in forum 2-Stroke Performance
    Replies: 6
    Last Post: 07-19-2009, 07:58 PM
  4. SLT750 questions...help please!
    By RustySeaRustyDoo in forum Polaris Open Discussion
    Replies: 9
    Last Post: 11-20-2006, 05:53 PM
  5. Quick Oil Question , help please!
    By NeverEndn in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-07-2006, 03:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •