Results 1 to 6 of 6
  1. #1

    GP1200R Slow Acceleration

    Today I was riding on my 2001 Gp1200 and its pretty much stock besides a grate. I was riding next to a stock 2002 gp1200 and it left me in the dust off the start. It cavitakes really bad off the start. What could cause mine to come off the line so slow? Could it need a pump seal? Should I do the jet works mod? Top speed and everything is good.
    Thanks A lot, Jerry


  2. #2
    philip_gpr's Avatar
    Join Date
    Dec 2005
    Location
    Canada
    Posts
    2,724
    +1
    3
    yes seal up the pump shoe with 3M 5200 and a pump plug kit
    the stock impeller is not that great - you could replace it with a solas 13/19
    you nay also need a new impeller liner - you should inspect yours for damage

  3. #3
    I am a honest believer in that ppk kit. It works absolute magic on these things. That's a first for a yami

  4. #4
    Could it possibly mean my jet pump is going bad?

  5. #5
    When I go on Cajundude it will not let me view the pump shoe installation link. I found some helpful tips in the how to section but they aren't very descriptive. Does anyone know of some better instructions? I have never messed with this part of my ski before. I'm guessing the grate comes out first then the impeller shaft? How does that come out? Please work with me considering this is greenhorn.net haha !

  6. #6
    yz450f's Avatar
    Join Date
    Aug 2008
    Location
    Long Island NY
    Posts
    657
    +1
    6
    Quote Originally Posted by philip_gpr View Post
    yes seal up the pump shoe with 3M 5200 and a pump plug kit
    the stock impeller is not that great - you could replace it with a solas 13/19
    you nay also need a new impeller liner - you should inspect yours for damage

    i dont know but i think 5200 is a little strong for that application and wouldnt it make it harder to take off for later repair or modification.

    wat about the 4200 fast cure?

    and definatley the ppk and u mite as well inspect the impellar and housing wile u have it apart.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wave Venture 760 slow acceleration (Cavitation?)
    By spride in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 08-25-2014, 08:50 AM
  2. fx ho slow acceleration, Impeller or housing?
    By solomondg1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-25-2014, 12:23 PM
  3. FZR w/GIO and Slow Acceleration-Related?
    By pro1200 in forum Yamaha PWC Performance (4-stroke)
    Replies: 21
    Last Post: 08-28-2012, 06:21 AM
  4. 1995 GTX Slow Acceleration
    By SeaDooNewBlood in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-21-2012, 07:55 PM
  5. New Problem -- GP1200R Poor Acceleration/Speed
    By cincygpr in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 09-08-2007, 05:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •