Results 1 to 5 of 5

Thread: OCMS, GIO

  1. #1
    axelderhund's Avatar
    Join Date
    Dec 2007
    Location
    Virginia Beach, VA
    Posts
    37

    OCMS, GIO

    Hello, I have an 07 250x with the famous GIO problem. It hasnt run right for a year, idling bad, and max speed of 40 mph (fast key). finally after going to the dealer about 6 times, they changed all spark plugs and oil at the same time. They told me that kawasaki's warranty paid for it, but probably will not next time. They told me that it is "a high performance jet ski, and should be driven as such". They said that idling/driving at anything other than WOT is not good. They also said not to let off the throttle too quickly because it pushes gas beyond the cylinder rings. Is this true, or BS?

    It ran fine for about 10 hours, then the engine starts to hesitate during acceleration from a dead stop, and its all downhill from here. My gps'd max speed was 62.7 w/ 195 lb driver, and clam waters. I have some plugs on order - CR9EK. I'm going to change the spark plugs myself and change the oil/filter since i dont want to hassle with the dealer's BS. I've heard of the ocms and r&d kit that is supposed to fix this problem. How effective is it, which one, or both do I need, and where can I get them? All of the links I've seen are dead. Thanks!

    I'm NEVER buying another Kawasaki as long as I live


  2. #2
    Someone said dont idle it much? well i fish (troll) at idle for hours on end with my 2 kids all the time, never had a problem doing that, ther must be something else wrong if you cant idle it with out hurting the plugs, i put new plugs in at 30 hours, and now have 80 hours on the 07 250x and still good.

  3. #3
    Quote Originally Posted by axelderhund View Post
    ...They told me that it is "a high performance jet ski, and should be driven as such". They said that idling/driving at anything other than WOT is not good...
    Ive never heard that you must go WOT wire to wire. Thats not practical. I did develop a suspicion, however, that excessive idling caused me problems, even though I could not understand why.

    The OCMS kit was a clever solution for many but I do not think it is currently available. Some have rigged their own catch can drain valves, however, that function the same way.

    I suggest you inspect your intercooler for fouling. The performance of my 07 usually returned to normal after I cleaned the intercooler, at least for a while.

  4. #4
    axelderhund's Avatar
    Join Date
    Dec 2007
    Location
    Virginia Beach, VA
    Posts
    37
    UPDATE!!!!

    So...I changed the plugs with CR9EK's, changed the oil and filter and put the correct amount of oil in (removed 5.5 quarts that reeked of gas, put 4 in!!!!). I pulled the intercooler and cleaned it out...lots of oil in there! I tensioned the supercharger pulley (waaaay loose) and installed a BOV block off. I also created a do-it-yourself OCMS rig by installing car hose and looping it coming ouf the the bottom of the oil collection can. Before, the jet ski would only do 62.7 at 7600 with a boost of 10 (according to the boost-o-meter on the ski). I took it out yesterday and ran 7780-7880 at 66.2 with a boost of 12. Very nice. I pulled out about 2 ounces of mostly gas/oil mix from the OCMS hose after I rode. It would have gone right into the oil.

  5. #5
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    Thats progress! There is more speed in there. As far as gas in oil, both kits are effective but the OCMS is a lot cheaper. I have the other and it works fine but I installed before OCMS. I would have gone the other way if it was out at the time. Did you advance your timing yet? Best bang for your buck that you can do cause all it costs is a little bit of your time and your gains are about 2-3 mph and 150-300 rpms.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NYS Consumer Protection Board 250x GIO
    By mugmainer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 04-14-2008, 11:49 PM
  2. Did kawi fix the GIO prob for 08?
    By mooneyb91084 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 04-08-2008, 07:45 PM
  3. Kawi and the GIO...again
    By benjahw in forum Kawasaki PWC Performance (4-stroke)
    Replies: 29
    Last Post: 03-13-2008, 08:02 AM
  4. The answer from Kawi on GIO.
    By BillyR-12X in forum Kawasaki Open Discussion
    Replies: 43
    Last Post: 11-29-2007, 11:26 AM
  5. The answer from Kawi on GIO.
    By BillyR-12X in forum Kawasaki PWC Performance (4-stroke)
    Replies: 43
    Last Post: 11-29-2007, 11:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •