Page 1 of 10 1 2 3 ... LastLast
Results 1 to 10 of 98

Thread: Broke d!ck RXT

  1. #1

    Broke d!ck RXT

    I went from 60 or so mph....7000rpm....to nothing...no codes....no warning....nothing....to nothing.

    Good tone on the dess......hit the start button and....click.

    I'd pulled the pump to tweek the prop and I'd finally gotten around to truing the grate. I hoped...maybe I ingested something and locked up the prop....nope....Maybe I fckd up greasing the pump....nope....everything was fine.

    I've tried to start it without the pump on.....nothing.

    For some reason...I'm thinking.........timing chain.

    Somebody tell me there is some small....inexpensive thing....that could be doing this.


  2. #2
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    would ponder a guess that u didnt upgrade the flywheel bolts and one let loose maybe.

  3. #3
    No...I hadn't done that. Didn't figure I was turning enough hp to warrant it.

  4. #4
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Speed was good for that RPM as well!

    Any spark at the plugs?

  5. #5
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Then take the PTO/driveshaft side Camshaft cap 2 bolts out, and have a look to see if the cam is turning.

    You can see the end to verify it.

    If my 2 posts say no spark, not turning cam, then your chain is gooone.

    Time to split the engine to replace it am afraid.

  6. #6

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    sounds like the starter selinoid to me. using pliers jump across both conections and see if the ski tunrs over. be sure the hull is vented of fumes as it will spark

    TLR

  7. #7
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Forgot this one... ooops.

    Battery gone flat after not charging on the water is a good one.

  8. #8
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Pull the sc and see if its locked up.

  9. #9
    Battery has less than 10 hrs on it...same for the relay.

    When you say sc "locked up"....you mean....not moving...even a little bit...right? Like checking to see if the washers are gone you should get a slight movement but not be able to spin it.

    right?

  10. #10
    Quote Originally Posted by TLR View Post
    sounds like the starter selinoid to me. using pliers jump across both conections and see if the ski tunrs over. be sure the hull is vented of fumes as it will spark

    TLR
    I did this on the water.....it does spark....nothing.

    Afterward I figured I'd have to get another relay.

Page 1 of 10 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 rxt- 260 variable trim BROKE! Please help!
    By Widowmaker in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-10-2011, 10:32 PM
  2. Broke fuel pump breather nipple 2005 RXT
    By Hondapro210 in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-16-2011, 07:27 AM
  3. RXT grate broke
    By cjo632racing in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-10-2011, 11:19 AM
  4. Uh oh... 2005 RXT Supercharger broke or ?
    By Humbucker427 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-08-2009, 08:55 PM
  5. RXT broke down this weekend
    By RXTridr in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-30-2009, 07:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •