Results 1 to 5 of 5
  1. #1

    Went out today, and had a restarting issue

    Well we had a good time out today but getting the old 95 slt started again after playing for a while was always a bit of a pain. You really had to give it some throttle to get it started. Then sometimes if you let it idle to long, when you give it gas it would stall out. I have changed the fuel lines as well as the filters and pump. Do I need to have the carbs rebuilt? Once you have it running its good to go tho,


  2. #2

    Join Date
    Jul 2007
    Location
    Alabama Gulf Coast
    Posts
    206
    If you've cleaned the carbs and replaced the fuel filters, what you need is carb tuning.
    http://www.greenhulk.net/forums/showthread.php?t=15473

    Go here, read, take notes and tune that baby. I found the best use of #5 and #15

  3. #3
    Have not messed with the carbs yet, I guess im still a little intimadated by em. But it looks like im going to have to get over it and get it done so it will run better. Where is the best place to get the kits from?

  4. #4

    Join Date
    Jul 2007
    Location
    Alabama Gulf Coast
    Posts
    206
    I don't know where to get the kits from since I just took mine apart, cleaned and put them back together. The word is though, use genuine mikuni parts for the best results.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by gorey View Post
    Have not messed with the carbs yet, I guess im still a little intimidated by em. But it looks like im going to have to get over it and get it done so it will run better.

    Where is the best place to get the kits from?
    Polaris parts sources listed here, part of this web site

    Good bets are Watcon and John Zigler.

    Click here for Mikuni carb rebuild info, and other useful info regarding the Fuji engine. Part of this related web site.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. had a cold spell today and went 79.41 :)
    By Branden in forum 4-Tec Performance
    Replies: 14
    Last Post: 11-05-2014, 12:20 AM
  2. went out today to gps my new fzs
    By mike1706 in forum Yamaha PWC Performance (4-stroke)
    Replies: 84
    Last Post: 09-16-2012, 08:37 AM
  3. Went rideing today and it sucked
    By FIRE0021 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 32
    Last Post: 02-16-2009, 12:26 AM
  4. Went to work today and took home a new friend
    By Shibby1485 in forum Open Discussion
    Replies: 11
    Last Post: 09-10-2007, 01:06 AM
  5. Went riding today, had some drama...
    By KeithKman in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 01-14-2007, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •