Results 1 to 3 of 3
  1. #1

    No spark on a 1997 Polaris 1050 SLTX

    Hi all,
    We have a pair of 1997 Polaris 1050 SLTX jet skis. No trouble with them in 2 years. This summer we started the at home...5 sec run. Mine ran fine, so did his. He then changed spark plugs on both. Mine still runs...his turns over and over but no starting!!! No spark to speak of when you pull a plug and ground it to the motor...Any suggestions? seems weird that it worked and then not right after the plug change. Anyone have this issue? ? plug wires? ?stop switch? ?CDI box? HELP PLEASE!!! It's driving him nuts!


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Welcome to Green Hulk.
    Using a volt meter,check the battery volts while cranking. Needs to be over 10.5 volts.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Welcome

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. no spark on polaris slx 1050
    By kuntrytyme in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 03-29-2012, 12:42 AM
  2. no spark on a 2001 polaris slh
    By nbiggott in forum Polaris Open Discussion
    Replies: 25
    Last Post: 09-08-2009, 06:43 PM
  3. No spark on a 99 slx 1050
    By Fandini in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 09-07-2009, 10:14 AM
  4. No Spark on 1997 SL1050
    By Syswatch in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-03-2009, 11:28 AM
  5. 1999 1050 SLTX, no spark on MAG Cylinder
    By dragpro in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-15-2008, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •