Results 1 to 6 of 6
  1. #1
    o0 RASTA 0o's Avatar
    Join Date
    Apr 2009
    Location
    Caribbean
    Posts
    196

    Question for MPeavler or Any Help

    Peavler,

    I have spoken to SBTand they have given me some pricings......However the heat sensor as you mentioned.....them nor Watercraft Superstore can help me. They do not have a part # and do not know what I am asking for. I am not a mechanic, so I really do not know exactly what it is I am trying to purchase. However, I know that I need the bike to cool properly, therefore I may need something like a thermostat that is used in a car. Normally, it is just a single piece. Can you help me locate this termosensor/thermostat/heat sensor?

    Watercraft Superstore # is 866 957 9277 - They told me to look at a diagram, but I have no idea what I am looking for.

    However, this is what I have from SBT so far.

    (1) 4 Engine Mounts (bought already)
    (2) SBT Break in oil @ $12.95
    (3) 3 Spark Plugs NGK BR8HS @ $2.95; Total: $8.85
    (4) Sealant Kit @ $19.95
    (5) Installation Gasket Kit @ $49.95
    (6) 3 Carbs Rebuild Kit @ $34.95; Total $104.85 (Do I need 3 or 1?)
    (7) Fuel Filter @ $3.69
    ( Thermosensor / Thermostat / Heat Sensor (need help with this one)
    (9) Fuel Pump - Is this necessary - Any help with this would be appreciated. Think mine is fine. Not sure though. If it stops working...will it damage the engine?

    These are all the parts that I am looking at to rebuild the powerplant properly. Any other suggestions...or just fine?

    Thanks alot man!


  2. #2
    o0 RASTA 0o's Avatar
    Join Date
    Apr 2009
    Location
    Caribbean
    Posts
    196
    Peavler,

    Spoke to a mechanic down here.....He told me that Since I though that my bike was overheating and I did not hear a buzzer.....That the thermosensor is bad. Further he said that I should just change the thermostat too which is what lets the water in to cool the engine. He then told me to not worry about the fuel pump b/c when I was gunning it...I was getting sufficient fuel pumped in order to make the speed which was more than 55 mph when I raced that Honda bike.

    I need to locate this
    (1) Thermostat
    (2) Thermosensor
    (3) Forget about the fuel pump

  3. #3
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Quote Originally Posted by o0 RASTA 0o View Post
    Peavler,

    Spoke to a mechanic down here.....He told me that Since I though that my bike was overheating and I did not hear a buzzer.....That the thermosensor is bad. Further he said that I should just change the thermostat too which is what lets the water in to cool the engine. He then told me to not worry about the fuel pump b/c when I was gunning it...I was getting sufficient fuel pumped in order to make the speed which was more than 55 mph when I raced that Honda bike.

    I need to locate this
    (1) Thermostat
    (2) Thermosensor
    (3) Forget about the fuel pump


    1st...you need a new Mechanic. That ski does not have a thermostat....it's a total loss water cooled system from the pump. It goes in the exhuast manifold and out the head to your stinger...then out the ski.

    2nd... just goto http://216.37.204.203/yamaha_OEM/Yam...e=13&A=43&B=13

    and you need part #43 if in fact your ski is going into limp mode..which limits RPM to 3k You have an indicator on your dash that shows temp warnings...nothing on it? How hot is the water coming from your outboard pisser? If you can keep your fingers in it...your not overheating.

    M

  4. #4
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    1+... to what MP posted.... outboards use thermostats to restrict and regulate cooling ..not skis...its pump and dump, heat of the engine is picked up along the way..

    please check the cooling for volume also.... a ski used in salt enviroment's will pick up alot of deposits (those f'n shells) that will restrict its ability to flow and even transfer heat properly (its like lime on a tea pot)

  5. #5
    o0 RASTA 0o's Avatar
    Join Date
    Apr 2009
    Location
    Caribbean
    Posts
    196

    Thanks

    Thanks for the info.....However, when it comes to the dash....there are 3 arrows that light up when I start it...for oil, temp, and gas. When problems were happening, none of those arrows were lit. Further, My speedometer does not work. It always reads zero, except for a couple occasions where it gave me a number while riding, but went back to zero very quickly.

    (1) What does this mean?

    (2) How do I fix it? What do I need?

    (3) Could this have been a contributing factor to the break down.

  6. #6
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Quote Originally Posted by o0 RASTA 0o View Post
    Thanks for the info.....However, when it comes to the dash....there are 3 arrows that light up when I start it...for oil, temp, and gas. When problems were happening, none of those arrows were lit. Further, My speedometer does not work. It always reads zero, except for a couple occasions where it gave me a number while riding, but went back to zero very quickly.

    (1) What does this mean? - Check for a loose wire and or a sticking wheel on your ride plate in the back.

    (2) How do I fix it? What do I need? See above

    (3) Could this have been a contributing factor to the break down.
    Nope

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. trade 04 rxp blown engine for xpl or any offer
    By abarrassr07 in forum Sea Doo 2 Stroke Skis
    Replies: 3
    Last Post: 08-30-2009, 03:15 PM
  2. Replies: 5
    Last Post: 06-25-2008, 02:40 PM
  3. Modding Questions for RXT (or possibly another type)
    By alias3r in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-25-2008, 06:40 PM
  4. Question for forum admisistrator or anyone who has answer
    By Sundance in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 12-11-2005, 02:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •