Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,274

    Jet Ski Emergency room- 2005 4-tec- no heartbeat

    It started out innocently enough for a monday...a 4-tec wake showed up with a rope wrapped around the prop..no big deal..

    or so I thought...

    As I went to lift the seat off after the general chitchat with eh owner, something was wrong....really wrong.

    The seat was totally waterlogged!

    I asked him..flipped this over to try to get the rope out?

    "yup"

    how long

    " I dunno, maybe an hour"

    ok..pull the plugs, get the rags and tell him the bad news

    quick geyser and he looks like I just told him his kid hit a schoolbus full of nuns head on after chugging a few beers at the local pre-school

    of course rope extraction was simple enough, I've had worse pumps to pull, got a couple of oil changes going and as the engine was nicely idling on the hose I heard a loud beep..and the instrument panel went dark..so did the engine.

    Cranks now but no spark and the display is dead. I went thru the wiring, checked the fuses, including the ones on the starter soleniod. Took a hard look at the mpem and ecu connectors, no water showing and the pins look good

    Now with the battery connected the idle control valve clunks open..and every now and then the ski gives off a long beeep..even without the lanyard attached.

    recognizes both lanyards and allows the engine to crank. Looked over all the ground wires too...battery voltage is in range.

    Ther was water int he harness going to the display, but all the connectors seemed to be in good shape.

    So is it time to buy a scan sea? I know if I have to replace anything on this ski I'll need it.

    ok fellows, I need your help here..something obvious I've missed?

    and here I thought it would be another slow monday, cleaning the tools and ordering parts....


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    From what I've read, Scan Sea is not going to help. Let us know if it does... Ron

  3. #3
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Member AHA went thru a very similar situation and fixed his problems, shoot him a PM and see how he got his fixed

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Sounds like possibly a bad DESS.

  5. #5
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    One thing I can tell you is that when they become that wet all kinds of strange electrical problems start to surface. I have actually had a few error codes/beeps go away after blowing a high velocity fan through the ski for a couple of days. Basic premise, get the water out of everything before you do more and go too far.

    All that said, I have never waterlogged the engine before. Just an idea for you to consider.

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,274
    I was thinking dess post also and agree about drying out...too bad we've had much rain here lately...pretty humid..I'll run my leaf blower in there for a while depending on what I see in the morning when I connect the battery again.

    It was full of water for at least 12 hours.

    In regards to scan sea, if I can't mate a new display or ECU with it, then what good is it?..be nice if the scan sea dealer (who I know is lurking around here) would come in and discuss exactly what can be done.

    I picked up a handheld a couple of weeks ago to handle my two stroke biz..don't see many 4-tecs for anything outside of this kind of work (without the electrical drama).

    I had mentioned in another thread, most of the 4-tecs that show up at my place have extended warranties, so there isn't too much I can get involved with. I can change oil and replace damaged props and what nots, but that's about it.

    There is that buzzing/hissing sound coming from somewhere in the hull, but I've opened up all the connectors to check for water..all seems pretty tight.

    First stop will be the DESS post..cheap enough for a hail mary unless somebody tells me otherwse. Seems like a logical fault point since the ski is beeping on it's own with no key, but won't ack that a valid key was in place.

    I'm getting it into the shop and crack the a/c on and play with the voltmeter tomorrow and try to knock some sense into it while it dries out.

    I suspect however, there is carnage someplace expensive. Stay tuned...

  7. #7
    Disconnect plug "A" on the ecm first, reconnect, then plug"B". Sounds like the ecm partially shorted. Dry the wireharness very well. That buzzing sound is in the tops switch to ecm. Do you have another ecm to try? As long as it is from a 02-05 it will work to verify. The ecm's are very sensitive to voltage/amp spikes to being connected to power and waterlogged. No connections are totally waterproof on seadoo's.

  8. #8
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,274
    I had the ecm connectors off to inspect, nothing notable, but I'll give it another go tomorrow. Don't have any spare ecu's..had a heck of a time finding it on the parts fiche..that's a high buck item for sure.

    Maybe with some luck,,there will be some dring action, but I kinda doubt it.

    I do need BUDS to install a new ecu from what I've read..true?

  9. #9
    2005? test the stator, the bolts have a bad habbit of backing out of the flywheel and chewing up the stator winding in that year, there is an update bolt kit to fix this problem. I worked on a ski a couple of weeks ago that did kinda the same thing, would beep with no key, and no spark.

  10. #10
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,274
    while that would be one of the uglier coincidences of my career, I'll pull the stator connector and giev it a look. Today I pulled every connector I could manage and blew them out with compressed air..let the ski bleach in the sun for a while.

    it'll get ugly when I call this fellow in a few days to inform him that his flipping the ski over to clear the rope just got _really_ expensive.

    But at least it ran long enough to save the engine from certain death by rust.

    Next up on my special "gotta make one" tool list is a gutted spark plug with a hose connected so I can make this process more manageable, if not so dam messy

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 52
    Last Post: 01-09-2014, 08:24 PM
  2. 2007 Sea Doo GTX 4-tec - 1st time jet ski buyer
    By golfgibson in forum 4-Tec Performance
    Replies: 11
    Last Post: 01-26-2013, 11:51 PM
  3. Replies: 1
    Last Post: 08-31-2011, 07:37 AM
  4. FS 2005 Sea Doo RxP Jet Ski 54.5 hrs
    By jklavall in forum Sea Doo 4Tec Skis
    Replies: 21
    Last Post: 07-19-2011, 03:28 PM
  5. Need help with Yamaha Jet ski ... No speed
    By welterracer in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-19-2007, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •