Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Does this look too lean?

    Ok, this is after about 7-8 hours on the rebuild. These pics were taken after about 3 consecutive 40ish second WOT runs. I already have the jettings pretty rich (don't remember exactly what they were), to the point where my wash should definitely be on the rich side. As long as I'm not in the danger zone I'm fine with it, but I dont really know.

    While running, it seems like the PTO is cool, the center is fairly cool, and the mag is kinda warm.

    Overall


    Center




    MAG



  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Yes. All of them look lean.

  3. #3
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    I agree. Also, without a super closeup and judging only by those pictures, the center looks as though you may be starting to have some damage. It may be just that picture though.

  4. #4
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    I agree with above...

  5. #5
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400

    jetting

    i'd start looking at fuel delivery,if i remember what you said you were running for jets it looks more like your just not getting enough fuel with enough pressure to the carbs,time for a pressure guage to check the return pressure.you have to hook it up between the pto carb return and the feed for the center carb to check

  6. #6
    Quote Originally Posted by TxPro1200 View Post
    i'd start looking at fuel delivery,if i remember what you said you were running for jets it looks more like your just not getting enough fuel with enough pressure to the carbs,time for a pressure guage to check the return pressure.you have to hook it up between the pto carb return and the feed for the center carb to check

    Yes, the way its currently jetted, it should definitely be running rich. I'm not really sure what you mean though. The gauge only has one input, where exactly do I put it?

  7. #7
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400

    pressure

    the center carb doesn't have a body mounted pump,its feed by the returns off the mag and pto.you need to install a tee in the line from the pto return to the cen carb v inlet.then connect your gauge to one end of the tee.my virage runs about 4-4.5 psi at wot

  8. #8
    Quote Originally Posted by TxPro1200 View Post
    the center carb doesn't have a body mounted pump,its feed by the returns off the mag and pto.you need to install a tee in the line from the pto return to the cen carb v inlet.then connect your gauge to one end of the tee.my virage runs about 4-4.5 psi at wot

    Ok, thanks. Can I bypass the water separator and just put an inline filter in?

  9. #9
    The pistons appear to be awfly loose in the jugs to me. They knock around a lot more than I would expect. And there was slight damage on at least one of the pistons before this rebuild, so you can disregard that.

    Someone who is recomended on here bored the cyls with the pistons in hand, so I would expect it to be good... But I know my pistons fit a lot tighter than that, and theyre OEM bore.

    Also, these pics are at about 8 to 9/10 throttle. The throttle cable was loose and it wasnt hitting full WOT.

  10. #10
    Ok, I just picked up a fuel pressure gauge. I hooked it up on the carb fuel line that goes between the pto and the cen cylinders. At idle I have 2 psi. When I throw it to WOT, the pressure spikes up slightly past 4, and then comes back down to 3psi while holding WOT. So, I'm assuming this is probably where my problem lies. I'm going to go out, bypass the waterseparator, and fuel switch and see what I get for pressure.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. would this be too lean???
    By bow tie klr in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 06-10-2009, 12:04 PM
  2. Before and After, Does this look...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 11-03-2006, 08:00 AM
  3. does this look ok...??
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 07-11-2006, 08:20 PM
  4. 05 pump- does this look ok to you?
    By idizzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 12-10-2005, 05:41 PM
  5. Does this look normal?
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-19-2005, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •