Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2008
    durban south africa

    Angry please help starting problems

    hi guys i have a seadoo gti rfi

    i cant seem to start the jet what it is doing is, when i put the key in i get the beeps then all that happens is the solinoid is clicking but the starter motor is turning but if i bridge the solinoid the motor turns perfect sooooo i asume that the positive and negative is fine. i thought it was a simple fix and i did put a new solinoid in but still the same problem

    please help

  2. #2
    TEX-X's Avatar
    Join Date
    Jul 2008
    Pecos, TX
    my Rxt X was doing the same....first off check all connections for physical security and signs of corrosion...mine ended up being the solenoid.... maybe the Dess post is at fault?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help! starting problem 02 virage txi
    By jhutson in forum Polaris Tech Tips and Info
    Replies: 1
    Last Post: 07-08-2013, 08:28 AM
  2. Need help - starting problem
    By FRPO in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-15-2013, 04:17 PM
  3. help starting problem
    By h.lurton in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-11-2010, 06:31 PM
  4. please help starting problems
    By buzz in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-30-2009, 07:12 PM
  5. gp1300r starting problem (help please)
    By Markb47 in forum Yamaha How To & FAQs
    Replies: 8
    Last Post: 06-26-2008, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts