Results 1 to 4 of 4
  1. #1

    94 SL750 cuts out and bogs at full throttle

    94 sl750 cuts out at full throttle. Accelerates fine until you reach full throttle and then it cuts out or bogs. Drop the throttle back and it goes again. Carbs have been rebuilt. Any suggestions?


  2. #2

    Join Date
    Jul 2007
    Alabama Gulf Coast
    High speed adjustment is off. Up to a certain throttle position you are running on fixed jets then the adjustable high speed needle takes over.
    If I had to guess, I'd say you need more fuel at WOT. Check your piston wash and go from there.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Are the fuel filters clean?

    Have you checked the pick up inside the tank?

    How are the fuel hoses?

    Did you check the petcock?

    Did you remove the autocock?

    Are you using a triple outlet fuel pump?

  4. #4
    thanks for the suggestions. I will check them out and let you know


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 93 sl 750 Poping in Carbs and Sputtering under full throttle
    By Scotty Dont in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-30-2011, 05:08 PM
  2. XL Limited cut out and won't start
    By yamxlt1200nj in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 08-05-2010, 08:18 PM
  3. Ski cutting out and losing power
    By TankerDriver in forum Polaris PWC Performance
    Replies: 6
    Last Post: 08-28-2009, 12:10 PM
  4. Replies: 18
    Last Post: 05-19-2009, 10:01 PM
  5. 96 SL700 bogs at full throttle
    By Nik33615 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-30-2008, 01:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts