Results 1 to 8 of 8

Thread: 99 ultra 150

  1. #1

    Join Date
    Jul 2009
    Location
    Florence,AL
    Posts
    4

    99 ultra 150 twisted crankshaft

    I bought an ultra 150 that doesnt run well.I took it to the shop and they said that the crankshaft was twisted on the back cylinder.They said if you bring the middle piston to TDC the front and back pistons should be even in the cylinders.So the shop I carried it to checked this and they were uneven by 1/8 of an inch.can that little of a difference make a big deal.


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Give us a little more on the not running well. I dont think I have ever heard of somebody twisting an ultra crank. With a little more info mabe we can help you track down whats wrong and make sure the mechanic isnt trying to twist something else Do a search here for the ultra 150 manual, it is avaliable as a pdf.

  3. #3

    twisted crank

    I am with the previous post. I dont think the crank would twist. You might have a crank bearing going out at the most. Do a compression test and if the # are within 5lbs of each other the problem would not be with the crank and would be in the fuel or ign circuit. Let us know what you find out.

  4. #4

    Join Date
    Jul 2009
    Location
    Florence,AL
    Posts
    4
    I did a compression test today and all three cylinders where 110.It seems to rev fine out of the water but in the water it wont rev up.it will only go about 5 mph

  5. #5

    Ultra

    Good news then, it's not the crank that is causing problems.

    I would start with the basics, try new plugs, trimming the wires back an 1/8th of an inch on the spark plug boot. Try looking at your pump, make sure you dont have any hot spots where the impellor is hitting the wear ring. Try all the easy stuff first then move on to more complicated.

    Oh and tell that shop to go **** themselves with the twisted crank theory.

    Si

  6. #6

    Join Date
    Jul 2009
    Location
    Florence,AL
    Posts
    4
    How do I check the wear ring?I did notice some scratches on the tube that the impeller is in,It looks like the impeller may have scraped it at some point.maybe it spins free out of water and rubs in the water causing it to bog.does this happen with worn bearings.I work on my bike but im new to pwc please bear with me,all help is greatly appreciated.thanks

  7. #7
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    You will need to pull the pump to check the clearance. Once its off you slip a feeler gauge between the prop and ring preferably in 3 places. The clearance should be arround .006. Also check for fore and aft play. Pull the tail cone and look at the bearings. If there is any water in there the bearings and seals need to be done. Worn bearing can let it move and hit or they can be tight and load it down.

  8. #8

    Join Date
    Jul 2009
    Location
    Florence,AL
    Posts
    4

    Its fixed

    ultraskiit has fixed my ski.It turned out that he lived just a couple of miles from me.he said the problem was in the cdi box,a coroded lead.he soldered it and didnt have to buy one.I never could have guessed it would turn out this good.this forum and its members willingness to help are priceless.im forever grateful

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need a jetpump for a 99 Ultra 150
    By mirefire in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 03-13-2008, 08:10 PM
  2. 99 ultra 150 CDI.. now where do I get the NGK R6918C-9 spark plugs?
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 02-25-2008, 11:41 PM
  3. 99 Ultra 150 won't start
    By wareameye in forum Kawasaki Open Discussion
    Replies: 12
    Last Post: 09-24-2007, 06:48 AM
  4. 99 Ultra 150 Pump bearing replacement
    By gilson in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-09-2007, 01:59 PM
  5. 99 Ultra 150 an weird problems
    By xplayer2885 in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 09-21-2006, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •