Results 1 to 7 of 7
  1. #1

    Extented jet pump problems

    Hi, I have a 1995 slt 750 that has a extended jet pump off of a 1996 slx 780. I had to replace the driveshaft and use the coupler. Everything bolted right up. After finishing the job it didn't look right. It looked a little turned to the left. When I took it out on lake for a test drive I found that it is pulling to the right. I have tried shimming and I am not fond of it. My question is why is it pulling to the right? Seems like whatever I try doesnt work and it is a little annoying riding with the right side of the boat highjacked in the air. HELP


  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    I believe the slx had an angled wedge. I'm not sure why the 96 slx780 was the only one that had it. You need a regular wedge. The 96 also came with a prop cone spacer. Did you install that?

  3. #3
    Where do I get a regular wedge? I am not sure what you are talking about with the nose cone. I replaced just the entire pump assembly, driveshaft and coupler.

  4. #4
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    There are a couple of wedges on ebay at the moment. Someone around here may have a spare also.

    Look at the cone on the end of the stator. Its mounted with 3 allen head bolts. Most have a one piece cone like you originally had. The 96 slx had a 2 piece cone.

  5. #5
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Here's the spacer....
    Attached Images Attached Images  

  6. #6
    CRAP, I listed the wrong doner ski. The jet pump came off of a 96 slt 780. Darn it.

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Can you post a pic please?

    What did you shim?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. xp 787 1996 jet pump problem
    By 306kev in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 03-25-2011, 01:49 PM
  2. 1999 GXT Jet Pump problem
    By jsl750&slt750 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-14-2010, 10:33 PM
  3. virage jet pump problems help
    By davere in forum Polaris Open Discussion
    Replies: 11
    Last Post: 05-28-2009, 11:31 PM
  4. Jet Pump problem??? I need direction
    By xxpertsonly in forum Polaris Open Discussion
    Replies: 31
    Last Post: 10-14-2007, 09:59 PM
  5. SLTX 97 Polaris,jet pump problem
    By grifter in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-24-2007, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •