Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2009
    Location
    Kalamazoo, MI
    Posts
    33

    '97 sltx 1050 only hitting 5200-5300 rpms in water

    I have a 97 sltx 1050 that will rev up to 5200-5300 in the water, but out of the water when it doesnt have a load on it, it will easily hit over 6000. Is there a possibility that my reed stoppers aren't working properly or is it a carb problem?? It has good compression and spark on all cylinders. New fuel lines and oil lines have been installed as well. Any help is appreciated.


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,572
    +1
    35
    Welcome to Green Hulk

    What exactly are your compression #'s ? What do the spark plugs look like ? Could you post a picture of the plugs.
    .Does it run smoothly when at 5300 rpm ?

  3. #3

    Join Date
    Jul 2009
    Location
    Kalamazoo, MI
    Posts
    33
    They all have good compression 120-125. All three spark plugs look different. We have been messing with the carbs and finally got them to the right setting. We tightened all the screws then did a full turn to each screw as stated in the carb settings in the manual. It runs decent at 5300 rpms, but it has a little bit of a hesitation. It will idle fine and everything, but won't go higher than 5300-5450 rpms..any help is appreciated.

  4. #4
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,572
    +1
    35
    The carb adjustment will show on the color of the plugs ,when you are having the problem.Sounds as you might have a cylinder not running right ,possible is has the wrong impeller. Pull the pump off and check the pump bearings.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 GTX 4TEC only hitting 5200 rpm?
    By WS6 GreeN in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-31-2015, 05:06 PM
  2. 2001 yamaha xl800 only goes to 5000 rpm in water
    By buymyyam33 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-04-2014, 02:18 PM
  3. Putting new rings on a 97 sltx 1050
    By grifter in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-23-2007, 07:54 AM
  4. weak power on 97 sltx 1050
    By grifter in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-13-2007, 05:02 PM
  5. 97 SLTX 1050 Ignition Upgrade???
    By mccann316 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 03-08-2007, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •