Results 1 to 6 of 6
  1. #1

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374

    R&D EFI controller??

    Has anyone had trouble with the red light not coming on, on your controller.
    Did a few runs yesterday and saw that the red (main) isn't coming on. I checked the ground and pull the conector apart but don't see anything wrong. I turn the crossover to 1 and still no light. It still seems to be adding fuel and the light will blink sometimes but it's not working right and now I'm worried about riding this weekend.
    The other two lights are working fine.


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    IMO get rid of it. I have had several with the red light out, and I didnt want to chance it.

  3. #3

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    Quote Originally Posted by WFO View Post
    IMO get rid of it. I have had several with the red light out, and I didnt want to chance it.
    And do want???????
    The others that you have seen was it still adding fuel?

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by mikel70 View Post
    And do want???????
    The others that you have seen was it still adding fuel?
    like, throw it away and get another controller

    I didnt run them for long because I didnt want to burn up a motor

  5. #5

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    Quote Originally Posted by WFO View Post
    like, throw it away and get another controller

    I didnt run them for long because I didnt want to burn up a motor
    I was afraid you were going to said that. Damn ski putting me in the poor house, 400.00 is a lot now days LOL
    Thanks for the info

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    MJE has one

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HOW TO SET YOUR EFI CONTROLLER...
    By Knr in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 05-08-2006, 07:11 AM
  2. EFI control unit testing
    By kevski in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-11-2006, 07:00 AM
  3. EFI control question
    By waterkneival in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 03-22-2006, 12:00 AM
  4. EFI CONTROLLER INSTRUCTIONS (USAGE, NOT INSTALLATION)
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 01-13-2006, 08:54 PM
  5. EFI CONTROLER & FUEL INJECTION SYSTEM FOR SALE
    By ABBOTT in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-06-2005, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •