Results 1 to 6 of 6
  1. #1

    Need help with SL750

    I just replace the bearing on the impeller and cant get the plastic cover over the drive shaft guide. (the part located about a inch or two from the rear of the crank shaft) Do I need to take the impeller off again and put the cover over the housing first?
    Now the plastic hose under the coupler broke off. Can this thing just be left off.
    Last edited by vector; 07-02-2009 at 06:56 PM. Reason: more info


  2. #2

    Join Date
    Mar 2009
    Location
    Syracuse New York
    Posts
    84
    No, you can pop it on over the thru hull bearing. It takes a little force but it will go. you can heat it up with a hair dryer to soften it up a little.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,572
    +1
    1,272
    Here is how I get my plastic coupler covers back on. I am sure there are other ways.

    BTW, if anyone has a really good way to get those plastic covers OFF without a huge effort, I am all ears
    My Virage hull has a mid-wall that makes it hard to get at the cover.

    I position the plastic cover to line up with the groove in the bearing, then put a large worm gear style hose clamp around the small end of the cover and the shell of the through-hull bearing.

    I snug up the gear clamp, and press the larger part of the cover onto the coupler as much as I can.

    As I continue to tighten the gear clamp, it squeezes the plastic cover over the metal bearing. Readjust the cover and gear clamp if things start to shift out of position.

    First time I did this, it took a few tries. Now it takes about two minutes.

    Once the cover snaps into place, check that it is not rubbing on the actual coupler inside. The put a smaller gear clamp on the cover collar to hold it in place.


  4. #4
    Now the plastic hose under the coupler broke off. I think it might be for the spedo. Can this thing just be left off. I see no reason for it in the first place.

  5. #5

    Join Date
    Jul 2007
    Location
    Alabama Gulf Coast
    Posts
    206
    This cover is there to prevent water from being slung up into the intake and electronics if the thru hull seal gives up. You shouldn't leave it off. Also, if the small tubing under that broke is the speedo, it will fill your hull when you put the ski in the water so be sure you fix that as well.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,572
    +1
    1,272
    Quote Originally Posted by vector View Post
    Now the plastic hose under the coupler broke off. I think it might be for the speedo.

    Can this thing just be left off? ...
    The nipple under the drive shaft is the pitot for the speedometer.

    You can order a new one, and in the meantime, you can plug the hole in the pitot fin with a bit of epoxy.

    Slide under the hull, and you will see the fin up inside the intake grate, near the front. There is a small hole on the leading edge of the fin. Put a little epoxy in there, and let it harden.

    That pitot hole doesn't look very big, but at speed, the water pressure in the tunnel is fairly high, and it will stream water into the hull if it is not sealed off.

    Water spraying around inside the hull is no good for the engine air intake.

    Click here for some photos.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help with 93 polaris sl750
    By hummmmmm123 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-23-2010, 12:52 AM
  2. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM
  3. OK, need help with the small stuff now
    By Smitty in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-13-2006, 01:55 PM
  4. Need help with a Sony Handycam
    By kenshin89 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-27-2006, 06:42 PM
  5. Need help with 04 S.C. rebuild
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-10-2006, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •