Results 1 to 6 of 6
  1. #1
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6

    variable speed oil pump on 94 650?

    on my 96 slx780 i have a rod connected to me carb rack to the oil pump. variable ratio right? ok on my 94 650 there is nothing, nothing at all, in my manual in shows some sort of cable but i dont see that either, I have a spare motor and i looked at that one and it doesn't have it either. am i missing something? how does it increase oil with rpm on the 94 sl650. Thanks Mike


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    My 94 had a linkage rod fro the oil pump to the carbs. Yes, variable pump.

    If there isn't anything connected to it, I'd think it was oiling full tilt.

    Does it smoke alot?

  3. #3
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    There does seem to be a little more smoke than other ski's, my 96 slx 780 has that arm your talking about and the manual says that later models had a cable actuated one that was mounted on the magneto cover but I dont have that either. Did polaris put a constant oil pump on there early ski's? its wierd there is no spot to even hook up a arm to connnect to the carb rack. The little nipple that sticks out is not threaded to attach anything too. Thanks Mike

  4. #4
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    94 had the constant ratio pump. In 95 they changed it to the variable ratio pump. Check diagrams... 94 is first image without the linkage.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	94 oil pump.jpg 
Views:	39 
Size:	46.6 KB 
ID:	139967   Click image for larger version. 

Name:	95 650 oil pump.jpg 
Views:	73 
Size:	32.1 KB 
ID:	139968  

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Nice Star.

    Guess my 94 650 was upgraded.

  6. #6
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    my ski still has the little nipple that sticks out of the left side of the oil pump, but it is not threaded and it just spins and spins either way, is this the way it is supposed to be? Thanks Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oil pump issues 94 650 sl
    By guitar jeff in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 05-16-2010, 07:14 PM
  2. Oil pump on genesis??
    By texoma in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-18-2007, 05:06 PM
  3. Speed Sensor Positioning on 94 SLT750
    By utahnewbie in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-01-2007, 08:48 AM
  4. Pro cdi and 780 will not work on 94 650..
    By Rodneyae in forum Polaris Open Discussion
    Replies: 25
    Last Post: 05-16-2007, 07:48 PM
  5. Missing Oil Pump on 06 models
    By bic1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-05-2006, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •