Results 1 to 5 of 5
  1. #1

    Need Help - 2006 RXP Oil Pump Housing Cracked

    I've got a 2006 RXP with a cracked oil pump housing that dumped oil into the bilge, shutting down the engine. The ski has 140 hours and no modifications. (It's the front oil pump housing - the one near the oil fill location.)

    My initial thought was a failed supercharger bearing, but I just pulled the S/C and it's in perfect condition.

    The ski was running great when the problem occurred - 7,000 RPMs at about 45 MPH. The first sign of trouble was a slight vibration - I thought I picked something up with the pump.

    I pulled the spark plugs and they're perfect. The engine turns over with the starter and doesn't make any odd noises or vibrations. I pulled the oil filter and found some aluminum shavings.

    Any ideas what the "root cause" of the failure is?

    What should I do next, pull the cylinder head or just remove the engine?

    Thanks in advance and I hope everyone has a Happy Fourth of July.


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

    Exclamation

    get with meirvin, he has a motor he is parting out

    http://greenhulk.net/forums/showthread.php?t=98548

  3. #3
    Thanks for the information and the link.

    Any guesses on the "root cause" of the failure?

    I haven't pulled the engine yet and I'm wondering if I've spun a bearing? I can't imagine that an oil pump housing would just crack on its own.

  4. #4
    did you pull out the normal oil filter or a different near the oil fill. I blew my SC up and want to make sure I don't have shavings. The normal oil filter didn't have anything

  5. #5
    Quote Originally Posted by Kinchyle View Post
    did you pull out the normal oil filter or a different near the oil fill. I blew my SC up and want to make sure I don't have shavings. The normal oil filter didn't have anything
    I pulled the normal oil filter and it had shavings.

    Much to my surprise, the supercharger is in perfect condition. Something else failed on my 140 hour ski that caused the oil pump housing to crack - I still have no idea what the "root cause" of the failure was?

    If I had to guess, maybe it spun a bearing and that's why there are fragments in the oil filter. It still makes me mad because that ski had been very well maintained and lived an easy life.

    I think I'm just going to sell it off as-is. I don't have the tools or the time to remove the engine and complete repairs.

    Thanks for the post and the bump - when I saw the thread on the front page I thought someone else was having the exact same problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help,, 2005 rxp swap into a 2006 model??
    By Justino in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-03-2016, 08:40 PM
  2. rxp x pump housing shaft removal help !!
    By supra_power2 in forum Sea Doo How To & FAQs
    Replies: 1
    Last Post: 10-16-2013, 08:11 AM
  3. 2006 rxp oil codes, need help bad.
    By Cooler in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-07-2010, 07:14 PM
  4. Need Help 2006 RXP (Viper Red) REG #
    By blowbyu in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 02-13-2009, 09:01 PM
  5. 04-05 RXP complete oil pump housing
    By jbombino in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 01-07-2009, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •