Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2008
    Location
    Tyler, Texas
    Posts
    18

    GP 800 runs good for a few minutes - then dies

    I was test riding a friends 1998 GP800 trying to troubleshoot a stalling problem. It seems as if it stalls after it runs for a few minutes. He thinks its carb related, while I'm thinking that its an electrical problem. Everything seems fine while riding for 5-10 minutes and then all of a suddenly the engine just dies as if someone hit the kill switch. The warning light will blink and beep. It will then start up again, but will die if you give it more than 1/3 throttle. There is plenty of gas, and plenty of oil, it doesnt seem hot, and it has a new battery and new spark plugs. It didn't start doing this until he topped off the fuel tank with fresh gas. Has anyone had a problem like this? Just trying to get some ideas before I tear into the carbs. Thanks!!


  2. #2
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    Check the compression first make sure its not seizing

  3. #3

    Join Date
    Jan 2009
    Location
    Rising Sun,Md
    Posts
    31
    I would pump some of that fuel into a clear 2 liter clean bottle.Let it set for 10 minutes and look for contamination.I've seen a lot of this in auto's lately.

  4. #4

    Join Date
    Jun 2008
    Location
    Tyler, Texas
    Posts
    18
    Quote Originally Posted by Flying Scotsman View Post
    Check the compression first make sure its not seizing
    Scotsman, you hit the nail on the head. I did a compression check...140 on the front, and ZERO on the back. It appears that it was seizing, and after a close look I noticed that the oil line for the rear cylinder popped off at the oil pump. Tear down time! Thanks

  5. #5
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    Wish it was something other
    Oil line off will do it every time.
    Hope the damage is minimal and your back up and running soon.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris virage runs great for a few mins then...
    By Gtfotroll in forum Polaris Open Discussion
    Replies: 15
    Last Post: 01-10-2016, 08:29 AM
  2. Replies: 3
    Last Post: 08-28-2014, 07:32 AM
  3. 98 GP 800 - Runs at idle to mid and than full bog
    By jchale in forum Yamaha Old School Skis
    Replies: 21
    Last Post: 06-13-2011, 04:37 PM
  4. Replies: 1
    Last Post: 10-13-2010, 11:23 AM
  5. 95 xp runs for 10 minutes then dies
    By 95xprider in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-09-2010, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •