Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    Trouble keeping my Polaris Virage running....

    Hey guys whats up? I'm a first time owner of a PWC and I actually just bought it today. It's a 2001 Polaris Virage with 75 hours on it...

    I honestly don't know the first thing about PWC's and am stuck on what to do from here. Here's what happens...

    I crank it up and it runs but seems to run kinda rough (in my opinion). It does smoke out of the back as well. I put it out on the water this evening and it really hesitates. I would give it some gas and would have to keep it at that certain RPM to keep it running but it would only run for a fairly short amount of time.

    When I would get on it or accelerate faster then it would immediately start to bog down and want to die. It died over 40 times in an hour.

    I went home and checked the plugs but they didn't look too bad. Just a little covered in oil.

    Any idea on where I should start to fix this problem? I greatly appreciate your help and I'm glad to be a fellow PWC owner as of today!

    My Virage is the 2 cylinder 700 engine and it is also carbuerated.

    The carburetor was cleaned 2-3 weeks ago and looks very nice on the inside.


  2. #2
    way2much2do's Avatar
    Join Date
    Jun 2008
    Location
    Michigan
    Posts
    234
    Welcome to the Hulk, Muddinking.

    Can you tell us what model Virage this is and what engine is in it? Is it carbureted or direct fuel injected?

    Please let us know this info and I'm sure there are some really helpful and experienced people who will try to assist you.

  3. #3
    Quote Originally Posted by way2much2do View Post
    Welcome to the Hulk, Muddinking.

    Can you tell us what model Virage this is and what engine is in it? Is it carbureted or direct fuel injected?

    Please let us know this info and I'm sure there are some really helpful and experienced people who will try to assist you.
    Thank you very much!

    I am actually not sure of the specs. Not really knowing what to look for. Will the Boat Hull ID tell me anything?

  4. #4
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,570
    +1
    34
    Quote Originally Posted by Muddinking View Post
    Thank you very much!

    I am actually not sure of the specs. Not really knowing what to look for. Will the Boat Hull ID tell me anything?
    Welcome to Green Hulk !
    Welcome to the PWC fun.

    The name on the side will tell us a lot. IE; Virage-Virage I- TX or TX I

  5. #5
    Quote Originally Posted by casey67 View Post
    Welcome to Green Hulk !
    Welcome to the PWC fun.

    The name on the side will tell us a lot. IE; Virage-Virage I- TX or TX I
    I looked all over the outside of the PWC and the only name it has on it is simply "Virage". No other names or symbols. Any clue?

  6. #6
    My Virage is the 2 cylinder 700 engine and it is also carbuerated.

    The carburetor was cleaned 2-3 weeks ago and looks very nice on the inside.

  7. #7
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,570
    +1
    34
    I'm pretty sure the single carb has an accelerator pump,with the air filter off, hit the gas lever to see if you get a squirt of gas into the carb.

    If the engine was running recently,the accel pump resevoir should have enough gas for a couple squirts. If not start it for a couple seconds.
    If the accel pump isn't working it will bogg.

  8. #8
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Are there any warnings on the MFD (display)?

  9. #9
    Quote Originally Posted by axgrider73 View Post
    Are there any warnings on the MFD (display)?
    No I haven't seen any warnings on the display. However, the display doesn't read extremely clear as it should when it was new. Do the MFD's appear in red on the display or anything?

  10. #10
    Quote Originally Posted by casey67 View Post
    I'm pretty sure the single carb has an accelerator pump,with the air filter off, hit the gas lever to see if you get a squirt of gas into the carb.

    If the engine was running recently,the accel pump resevoir should have enough gas for a couple squirts. If not start it for a couple seconds.
    If the accel pump isn't working it will bogg.
    I will try this tomorrow and update the thread. Any other possibilities that I can try at the same time? Thank you for the help!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris virage runs great for a few mins then...
    By Gtfotroll in forum Polaris Open Discussion
    Replies: 15
    Last Post: 01-10-2016, 08:29 AM
  2. Please Help Me with my Polaris Virage TXi & Genesis i
    By Keith4281 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 02-02-2013, 09:29 AM
  3. 2001 polaris virage running issues!
    By 2000 gtx rfi in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 08-30-2011, 04:20 PM
  4. why is my polaris slth running fine for a bit then dying out
    By kastay29 in forum Polaris How To & FAQs
    Replies: 26
    Last Post: 06-14-2011, 01:11 PM
  5. Can't start my polaris virage i 2002
    By jitan2004 in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-06-2009, 11:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •