Results 1 to 2 of 2
  1. #1

    Join Date
    Jul 2009
    Columbia City, Indiana

    1997 Waveventure 760 Exhaust

    Anybody have a solution for the bolts constantly coming loose on the upper exhaust chmber casting. The lower bosses have broken off and each one of the otehr mounting points are slowly stripping out (locktite won't hold the bolts in anymore) I really don't want to spend the $230 to buy a new part when the old works great, just can't keep the bolts in!!!

  2. #2

    Join Date
    Jun 2007
    Mooresville, NC (Lake Norman)
    The problem is that once some strip or break, it puts more stress and vibration on the others, and then they go.

    I'd remove the pipe, Heli-coil the stripped threads or TimeCert them, and then re-assemble with Red Loctite. You can get used 64X pipes on eBay for very cheap - or try on here or

    Good luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 WaveVenture 760 Won't Start
    By JohnCiccarelli in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 12-31-2011, 01:40 PM
  2. 1997 Waveventure 760 engine problems!! Updated with pics
    By vitalka89 in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 08-02-2011, 06:08 PM
  3. 1997 yamaha waveventure 760 need engine help!!
    By vitalka89 in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 07-31-2011, 07:14 PM
  4. 97 WaveVenture 760
    By sunshine_n_pc in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 07-07-2009, 03:42 PM
  5. 1997 Gp 760 Jet Pump Help
    By ON EMPTY in forum Yamaha Old School Skis
    Replies: 8
    Last Post: 08-06-2008, 09:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts