Results 1 to 5 of 5
  1. #1

    RXT low speed stumble/miss

    2005 RXT and I started getting a low speed stumble/miss when only slightly on the trottle before planing out. Its not a huge problem if I can it there is no missing its like only under a fairly heavy load (before being planed) and not on the throttle hard. Anyone experienced this or have any ideas? Maybe I should replace the plugs see if that is it?


  2. #2
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    do the plugs. check all reg. maint items.

  3. #3

    Join Date
    May 2009
    Location
    SC
    Posts
    81
    +1 on plugs

  4. #4
    Chris0060's Avatar
    Join Date
    Sep 2007
    Location
    CT
    Posts
    1,174
    +2 on plugs...check your coils...

  5. #5
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    +3 un the plugs!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLTH 700 low speed stumble??
    By Vince ski in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-13-2015, 08:58 PM
  2. RXT - Low vibrating rumble. No speed. Help?
    By TheEngineer in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-26-2010, 01:01 PM
  3. 99 genesis ficht missing at low speed
    By RandyH in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-08-2010, 08:05 AM
  4. Polaris SLT 780 misses at low speed
    By tbock in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-05-2008, 12:19 AM
  5. 250X low speed miss morphs into now it won't run
    By reallybigboat in forum Kawasaki PWC Performance (4-stroke)
    Replies: 40
    Last Post: 02-12-2008, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •