Results 1 to 4 of 4
  1. #1

    SLT 780 question

    Our SLT 780 was running fine. But some friends were doing tricks in some shallow water and I think they sucked up some sand in to the cooling system.

    The ski runs fine for about 2 minutes. After that it tends to just idle down. If you let it sit for 5-10 minute it will run fine again for 2-3 minutes.
    I have flushed out the cooling system with a hose in both directions. All cylinders seem to be running cool when I have it hooked to the hose from the house. But on the water we have the same results.

    Any suggestions?

  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Welcome to Green Hulk.

    The cooling water is supplied from the jet pump. There is a small screen in the exit nozzle ( right where the large pipe attaches to the outside ) Make sure you check thet screen / back flush that tube.

  3. #3
    thanks for the suggestion. I will give that a try tonight.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Welcome to the Hulk.

    First rule, NEVER let your friends ride your ski......

    Also check the filter/screen behind the top fitting on the exhaust pipe. It has the hose that runs from it to the middle of the pipe.

    Also check the exhaust hose from the waterbox going out. If it ever overheated, it will get really soft and collapse when running.

    If it's soft, replace it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 SLT 780 LCD gauge question
    By polaris 700cc in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 10-13-2009, 01:21 PM
  2. 1997 slt 780 piston question?
    By dustin88 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 12-09-2008, 10:31 PM
  3. Newbee questions for a polaris slt 780!!
    By polaris in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 10-08-2008, 11:28 PM
  4. slt 780 idle question?
    By dustin88 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-29-2008, 09:48 AM
  5. 96 SLT 780 questions
    By BBCaprice in forum Polaris Open Discussion
    Replies: 13
    Last Post: 05-14-2007, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts