Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Aug 2007
    Location
    Chattanooga, TN
    Posts
    31
    +1
    1

    Uh oh... 2005 RXT Supercharger broke or ?

    I hope I'm not another statistic... again!

    Back in late 2007 I bought a 2005 RXT with a blown supercharger (I didn;t know it at the time). Within a couple days I figured it out and took it to the local dealer who fixed it under warranty minus a few hundred bucks. I was quite lucky to get that I think.

    Anyway, it's been ridden 6 hours since then and I took it out on the lake for the first time this year yesterday and a strange thing was happening. I idled out about 200 yards past the no wake zone, and then eased onto the throttle. It was spuddering and surging like it was missing or soemthing. At times it would pull VERY hard up to 45 MPH or so and then lose power. It all seemed very intermittant, but it never made proper RPM or speed. It was very low on fuel, so I'm hoping it's a clogged fuel filter, but you know how it is... It's never that easy.

    I'll be pulling it out of the water (it's on a lift) and getting it home this weekend and checking the supercharger, but I'm thinking it isn;t that because at times it does pull really hard. Much harder than it did when the supercharger was blown the last time.

    Any ideas on what I should start with other than the SC? Is the fuel filter a common problem on these? Perhaps clogged jets?

    Thanks!


  2. #2
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    I would start with fresh fuel and spark plugs. If the fuel has been in there that long it could be the problem.

  3. #3
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    As Dave said check the fuel and plugs..while you at it, check your coils..

  4. #4
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    start yor engine check supercharger outlet hose if its hard yor supercharger is ok.

    Then go on checking your spark.

  5. #5
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    If a dealer rebuilt your SC in 2007, it probably still has ceramic washers in it. Pull the hose from the SC and see if you can spin it. If you can, the washers are gone again... Ron

  6. #6

    Join Date
    Aug 2007
    Location
    Chattanooga, TN
    Posts
    31
    +1
    1
    SC turned out to be fine. I changed the plugs (plug 1 was fouled) and now all is well. Runs like a scalded dog.

    Thanks guys!

  7. #7
    That's always a positive. Glad to hear your ski is OK. Issues like this are scary for me. I've been out of the PWC game for a while and am just starting to consider getting back in. My old ski was a 1300R, so things like supercharger issues are...scary to say the least.

  8. #8
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Again, if the SC was rebuilt by a dealer in 2007, it still has ceramic washers unless you know otherwise. If they are ceramic, you might consider changing them... Ron

  9. #9
    AdrianRXT AdrianRXT's Avatar
    Join Date
    Jan 2009
    Location
    miami
    Posts
    198
    My 07 stock rxt loves to eat eat up spark. I remember the first time it gave me spark plug problems with just around 16 hours i took it to the dealer and they said just change the spark and always keep spares. =d>

  10. #10
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,567
    +1
    4,784
    6 operating hours since 2007.... DUDE!!!!
    welcome to the forum...
    P.S. - get rid of those ceramic washers yesterday, read this:
    http://www.greenhulk.net/forums/showthread.php?t=19887

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 RXT DESS ECU or MPEM problem? Help please!
    By rpexjr in forum Sea Doo ECU Support
    Replies: 6
    Last Post: 07-28-2015, 01:28 PM
  2. 2005 RXT supercharger noise
    By kdmart in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-17-2013, 09:41 PM
  3. FS 2005 RXT Supercharged Feeler
    By wademcgee in forum Sea Doo 4Tec Skis
    Replies: 6
    Last Post: 05-25-2013, 01:30 PM
  4. 2005 RXT Complete or Part OUT! Cali.
    By xpl2008 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 05-26-2009, 01:55 PM
  5. 2005 RXT or RXP owners manual
    By jack in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 06-22-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •