Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    2005 RXP won't run but 55 mph

    I have a 2005 RXP and it will not run but 55 mph wide open. I had it out just the other day and it had no problems. I dropped iot in today and it runs like a top...no noises, no hesitation, no nothing. It just runs like I have the beginner key on. Any ideas on what the heck is wrong??? I need all the help I can get.


  2. #2
    NastyStang's Avatar
    Join Date
    Jun 2009
    Location
    Central Florida
    Posts
    156
    +1
    3
    Supercharger is toast probably.

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by rockydood41 View Post
    I have a 2005 RXP and it will not run but 55 mph wide open. I had it out just the other day and it had no problems. I dropped iot in today and it runs like a top...no noises, no hesitation, no nothing. It just runs like I have the beginner key on. Any ideas on what the heck is wrong??? I need all the help I can get.

    Rocky, First off let me welcome you to Greenhulk.net...

    Now to the ski..What were your RPMs at this speed??

  4. #4
    Right at 5300 or so if remember correctly

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by rockydood41 View Post
    Right at 5300 or so if remember correctly

    Like Nasty Stang said..More than likely your Scer clutches let go....Heres a quick way to tell..Look down in the engine compartment..Youll see a hose that goes on the FRONT of the Scer..Take that hose off and stick your finger in there and see if you can spin the Scer wheel freely..IF so,then your clutches are gone...OH and when doing this..Make sure the ski IS NOT running..

  6. #6
    I'll give it a try, but I'm not too familiar with these things.

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by rockydood41 View Post
    I'll give it a try, but I'm not too familiar with these things.

    Understandable...Take your time..

  8. #8
    I found it, but I am afraid if I take the hose off I can't get it back on. Can the supercharger be rebuit, or does it have to be replaced?

  9. #9
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    It's not just the SC that needs to be rebuilt, it's the engine - due to all of the ceramic pieces getting into the oil pumps. Do you happen to have the extended warranty? If not, it is going to be very expensive unless you DIY... Ron

  10. #10
    No warranty that I know if, I bought it used. Bought it from a mechanic actually that said there was no problems. I have only ridden the dang thing 3 hours!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 RXP Won't Start
    By boostedz06 in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-25-2016, 08:42 AM
  2. 2005 RXP Won't Start, Chek Engine on the display
    By tpd in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-17-2012, 06:59 AM
  3. 2005 rxp idling and running like crap!
    By squishy18 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-03-2012, 03:10 PM
  4. Replies: 22
    Last Post: 06-16-2012, 02:47 PM
  5. RXP won't run right after mods - Limp Home Mode?
    By snowrunner in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-03-2008, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •