Results 1 to 4 of 4

Thread: power loss

  1. #1

    Join Date
    May 2009
    Location
    long island
    Posts
    9

    power loss

    hey i took my ultra 150 out today and after about 10 to 15 mins of rideing i felt a big power loss it would top out at only 30 mph and the rpm would only go up to around 4500.....moments before i was flying.........i went home took the plugs out and cleaned them up a bit fired her up(out of the water) and she reved all they way up.....any ideas of what happened?


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    My bet is you fouled a plug. Put a new set in and get a spare set to keep in the ski if it happens again. Just a tip next time it happens feel the plug bases after its been running. You should notice one being cooler than the others. That would be your fouled one.

  3. #3
    I'M BAAAAAAAACK wrenchedexcess's Avatar
    Join Date
    Jun 2009
    Location
    Houston, TX
    Posts
    53
    Quote Originally Posted by btldigger View Post
    My bet is you fouled a plug. Put a new set in and get a spare set to keep in the ski if it happens again. Just a tip next time it happens feel the plug bases after its been running. You should notice one being cooler than the others. That would be your fouled one.
    +1. You're not firing on all cylinders. Did the engine feel unbalanced and the stroke lumpy when you revved it?

  4. #4

    Join Date
    May 2009
    Location
    long island
    Posts
    9
    Quote Originally Posted by wrenchedexcess View Post
    +1. You're not firing on all cylinders. Did the engine feel unbalanced and the stroke lumpy when you revved it?
    it felt fine it acted as if a learner key was on it.....i pulled the plug ad only one looked fouled but i cleaned it up and she ran well.....i just put these new plugs in like 3 weeks ago and they only have maybe 7 hours on them i dont know why they'd be fouled already

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, need the experts!! 2006 RXP Power Loss
    By tampa_m5 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 10-03-2016, 08:56 PM
  2. gpr 1300 power loss
    By nobbyq in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-23-2008, 04:14 PM
  3. Help with diagnosing power loss in 3D
    By Jas in forum 2-Stroke Performance
    Replies: 15
    Last Post: 12-05-2007, 10:33 PM
  4. Power loss
    By rfjr23 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-12-2007, 01:22 AM
  5. Power loss
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 04-28-2007, 10:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •