Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Need Speed

  1. #1

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281

    Need Speed

    I just put on my new Rotax Racing Supercharger impeller and the 42# injectors. My boost went from 6.8 to 8.4 at wide open throttle. My speed went from 71.3 to 72.8 (GPS). I finally got to the 8400 rpm with my RR ecu. Before new supercharger impeller it was 8250 rpm. What is holding me back from the 75 to 76 mph range? I would think the mods I have would get me there. Any thoughts?


  2. #2
    Gforce's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    405
    Should you be running a 15/20r with that setup?

  3. #3

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    Are you bouncing off rev limiter? The 15/20 prop should be the way to go but not sure if you have enough horsepower to turn it. You might be a bit short.

  4. #4

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281
    Quote Originally Posted by smc
    Are you bouncing off rev limiter? The 15/20 prop should be the way to go but not sure if you have enough horsepower to turn it. You might be a bit short.
    What are you turning on your ski?

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    The 14/19 is your problem. You need the 15/20 with 2mm taken out of the trailing edge.

  6. #6

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965

    Rxp04

    Running stock Solas 15/20. Jerry what do you think?

  7. #7

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281
    Quote Originally Posted by Green Hulk
    The 14/19 is your problem. You need the 15/20 with 2mm taken out of the trailing edge.
    OK, Im going to give it a try. Thanks

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by smc
    Running stock Solas 15/20. Jerry what do you think?
    What are your RPM's?

  9. #9
    xenonx's Avatar
    Join Date
    Feb 2006
    Location
    Woodland Hills, CA
    Posts
    237
    Quote Originally Posted by RXP04
    I just put on my new Rotax Racing Supercharger impeller and the 42# injectors. My boost went from 6.8 to 8.4 at wide open throttle. My speed went from 71.3 to 72.8 (GPS). I finally got to the 8400 rpm with my RR ecu. Before new supercharger impeller it was 8250 rpm. What is holding me back from the 75 to 76 mph range? I would think the mods I have would get me there. Any thoughts?
    Sounds like the boost is a little low if you are running an external IC and the new RR SC. What RPM are you measuring boost?

    I would re-seal IC blockoff and go over every coupler from the SC to IC to throttle body. Make sure you do not have any leaks.

  10. #10

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691
    Quote Originally Posted by xenonx
    Sounds like the boost is a little low if you are running an external IC and the new RR SC. What RPM are you measuring boost?

    I would re-seal IC blockoff and go over every coupler from the SC to IC to throttle body. Make sure you do not have any leaks.
    In my opinion, he doesn't have any boost leak, did you check his engine mods?? he have the ****RR IC**** this is the reason for his low boost reading.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. First rebuild 04 xlt 1200 need speed secrets
    By malibu65 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-06-2009, 09:12 PM
  2. Get your need for speed here...
    By Smitty in forum Videos & Pictures
    Replies: 11
    Last Post: 04-15-2006, 09:26 PM
  3. Need For Speed
    By ph2ocraft in forum Yamaha Open Discussion
    Replies: 11
    Last Post: 01-07-2006, 01:55 AM
  4. Need Speed
    By Green Hornet in forum 4-Tec Performance
    Replies: 11
    Last Post: 12-24-2005, 10:08 PM
  5. Need help: Speed is down 3 mph even though it is colder out
    By UTClason in forum 4-Tec Performance
    Replies: 14
    Last Post: 12-15-2005, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •