Results 1 to 4 of 4
  1. #1

    msx 140 power lost

    hi guys sorry tu cut thru but i have a question. i bought a 2003 polaris msx 140 and the first four or five times i took it to the water was running great but after that it started tu run rough picking up speed and the engine sounded kind of bumpy. i am an auto mechanic but dont know to much of pwc so i started cheking fo damages and i found the fuel pump sending unit broken on top so i started removing the fule tank to chek the pump and the pressure valve but how da f.... does it come out? do u have to remove the stairofoam from the hull? and some ideas to solve my problems woul be great. thaks a lot guys


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by davidriccimsx140 View Post
    hi guys sorry tu cut thru but i have a question.

    I bought a 2003 Polaris MSX 140 and the first four or five times i took it to the water was running great but after that it started to run rough picking up speed and the engine sounded kind of bumpy.

    I am an auto mechanic but don't know to much of pwc so i started checking for damages and i found the fuel pump sending unit broken on top so i started removing the fuel tank to check the pump and the pressure valve

    but how da f.... does it come out? do u have to remove the Styrofoam from the hull? and some ideas to solve my problems would be great.

    thanks a lot guys
    Are you sure you need to remove the fuel tank to get the fuel pump out?

    I have not removed an MSX 140 fuel pump (yet), but on my Virage TXi I just slid the tank forward as far as it would go, and there was just enough room to get the fuel pump clear of the hull.

    What exactly is broken on the fuel pump?

    Oh yes - welcome to the Hulk

  3. #3

    msx 140 power lost

    hi guys sorry tu cut thru but i have a question. i bought a 2003 polaris msx 140 and the first four or five times i took it to the water was running great but after that it started tu run rough picking up speed and the engine sounded kind of bumpy. i am an auto mechanic but dont know to much of pwc so i started cheking fo damages and i found the fuel pump sending unit broken on top so i started removing the fule tank to chek the pump and the pressure valve but how da f.... does it come out? do u have to remove the stairofoam from the hull? and some ideas to solve my problems woul be great. thaks a lot guys

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Check the tech section, K447 did a write up on fuel pump repair for injected engines.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My 2003 msx 140 runs good under power but dies at idle
    By Adco1110 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 08-15-2016, 07:20 PM
  2. 03 MSX 140 no power
    By JeepMann in forum MSX/Matrix
    Replies: 15
    Last Post: 08-17-2012, 03:37 AM
  3. MSX 140 Overheated- then no power and SLOW mode
    By DRIFTER in forum Polaris Open Discussion
    Replies: 12
    Last Post: 01-17-2011, 12:43 PM
  4. Replies: 45
    Last Post: 04-07-2010, 10:53 PM
  5. MSX 140 Loses power
    By dpetrotta in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-26-2008, 02:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •