Results 1 to 2 of 2

Thread: Fx Ho no spark

  1. #1

    Fx Ho no spark

    Hello everyone.

    I have a 05 fxho that is kicking my butt. It only fires once n a while. I have tried every thing I can think of but end up with the same result. Here is all that i have eliminated thus far. coil's , pulser coils, thermoswitches engine and exhaust, ecm,cam position sensor, tilt switch ,kill sitch. I installed a known good part on all but the thermoswitches but they check out by the manual. also the ecm I tried is a fx 140 it is a different part # but the original ho works on the 140.Thanks in advance.


  2. #2
    there are differences between the ecu's. depending on years. things like the individual coils compared to the 2 coils on the fx140. just something to consider.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How To: Spark Plugs... Many pics and details
    By Shibby1485 in forum Sea Doo How To & FAQs
    Replies: 60
    Last Post: 07-18-2013, 05:17 PM
  2. How-To: Spark Plugs
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 9
    Last Post: 01-23-2009, 05:16 PM
  3. Spark plugs... pictures of old and new, Normal?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-08-2005, 10:12 PM
  4. Where to buy spark plugs??
    By mgo7483 in forum 4-Tec Performance
    Replies: 33
    Last Post: 07-08-2005, 07:44 PM
  5. Spark Plug gap??
    By Cutter in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-07-2005, 03:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts